Syncthing on Synology - how to access synced files

I’m merely an amateur, so please don’t be too hard on me if this is a silly question.

I’ve just installed Syncthing on a Synology DS218J. I wanted to set up the sync to a folder inside the ‘home’ folder on my Synology, but it gave a permissions error. I thought until I’d worked out what that was, I’d let it store a backup in the ‘default’ directory as a test (volume1/@appstore/syncthing/var) It’s done that, but I can’t access the files. I’ve managed to ssh into the NAS, but it won’t let me in the /var folder.

So 2 questions:

  1. how can I access the files in the location shown above
  2. how can I get it to backup files into the home directory?

As an aside, why would it store backups in such an inaccessible location? Am I missing something?

Thanks in advance. Tim

I think you have DSM 6.x installed on your DS. Make sure that you have correctly set the permissions for the relevant directories:

Control panel > group > “syncthing” > edit > tab permissions > check read/write

Then set “Ignore permissions” in the settings of corresponding peer in the Syncthing GUI.

Which Syncthing version do you have installed, from Kastelo or Safihre? In any case, you can read something about it here.

Hi Andy - thanks for the response.

I have DSM 6.2.2-nnnn and am using the Safihre version of Syncthing. I’d already got the first part of the permissions thing sorted, but not the ‘ignore permissions’ in syncthing GUI - thanks for that (it even says in the notes by the checkbox that it’s useful for Synology!)

In the meantime, I think I’ve sorted both questions.

  1. I used ‘sudo’ to enter the directory and manually deleted the backups
  2. I navigated around in the ssh into the nas to find out what the ‘real’ folder structure was of the locations I wanted to use and used these in Syncthing



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.