Syncthing on Synology DSM 7.0: Permission Denied - sc-syncthing user is hidden, group membership doesn't help

After upgrading my Synology RS819 to DSM 7.0, I just cannot seem to get Syncthing (the SynoCommunity version, build 1.17.0-22) working. I keep getting the following permission errors:

2021-10-01 16:26:34: Failed to create folder root directory stat /volume1/Photos/Pictures: permission denied 
2021-10-01 16:26:34: Error on folder "oracles - photos" (<folderid>): stat /volume1/Photos/Pictures: permission denied 
2021-10-01 16:26:48: Loading ignores: lstat /volume1/Photos/Pictures/.stignore: permission denied 
2021-10-01 16:26:48: Failed to create folder root directory stat /volume1/Photos/Pictures: permission denied 
2021-10-01 16:26:48: Error on folder "oracles - photos" (<folderid>): stat /volume1/Photos/Pictures: permission denied

where folderid is replaced with the syncthing folder id.

I have been scouring the internet for answers and have come up empty handed. I have confirmed that all of the users I’ve created in the DSM GUI have access to the syncthing group and that the syncthing group has read/write access to the folders I want to share. I’ve granted the users group access to syncthing and the folders it needs access to. I’ve searched for this mythical “sc-syncthing” user and I cannot find it, apart from going to etc/passwd via ssh and finding out that it exists but it is in the nologin folder. It’s not visible in the Users or Groups GUI at all.

Does the SynoCommunity edition of Syncthing still run as the sc-syncthing user? If so, then why can’t I get to it apart from digging deep into the command line (something I’m not terribly comfortable doing)? If not, what’s going on here?

You have in the DSM 3 possibilities to set permissions: lokal user, lokal group, internal systemuser. That Syncthing have permissions in the relevant folders, is enough to set the permissions of the user sc-syncthing in the internal systemuser area.

In DSM 6 that user permissions can set under lokal group, is more easy if you have more than one shared folder.

I am not sure what you just said, but I think I’ve already tried what you’ve suggested. All of the users I use (non-default accounts) have access to the Syncthing group and the syncthing group has access to the folders I want to share but I am still getting permissions errors.

Doe you set the “Ignore Permission” option in each folder? If no, is to set.

Doe you only have permission problems in such system folder as photo?

If the problem persists, there is another option via the ACLs.

Went to the respective subdirectory via the console (e.g. PuTTY, WinSCP). Mark all contents in the directory, i.e. sub-folders and files and set the permissions to root:root and octal 0777.

Went to the same directory in the DSM Filestation and inherit the permission information from the root directory into the subdirectories and files below.

This process helps “straighten out” ACL related issues. If there are problems, I have already done this and as a rule, maybe not always, it solves synchronization problems.

Just to be sure, you’ve allowed access for the sc-syncthing group in the ‘System internal user’ list in Control Panel for the Shared Folder?

image

If yes, this is the right way, another is not possible.

Yes, I set Ignore Permissions on the folders I am trying to sync. That did not help. I tried adding another folder but had the same permisson-related issues.