syncthing on OSX 10.11

I gather from searching for El Capitan that recent versions (within “the last few years”) will not work for OSX 10.11. I would like to enable sync between a machine running under El Cap (OSX 10.11) and another under High Sierra (OSX 10.13). Can I do this with older versions of Sync. and where can I get such an older version? Thank you. (And for the inevitable replies recommending upgrading OS… thank you but that’s not an option for me).

According to official go documentation, the last go runtime that supported macOS 10.11 was go 1.14 (see this and this for other versions):

(Go 1.14 Release Notes - The Go Programming Language)

The last syncthing release built with go 1.14 was according to syncthing documentation (Versions & Releases — Syncthing documentation) syncthing v1.8.0 (released 2020-08-11).

All official syncthing releases can be found on GitHub. Syncthing v1.8.0 is here. It goes without saying neither this version of syncthing nor its runtime receive any support.


Thank you! I’ll give it a try and report back.

1 Like

Hi again… sorry for delay it took a while to find time to tinker with this problem. I went to the page for the official release of v.1.8.0, and downloaded a zip for the MacOS, but it does not contain an application that I can run. It contains a Unix executable. I imagine there is some process by which I can use these release files to (compile?) an application? Maybe I need to use the command line? Can anyone help? thanks Boris

I know barely anything about macOS, but the release definetly contains a binary executable for macOS:

# unzip
# file syncthing-macos-amd64-v1.8.0/syncthing 
syncthing: Mach-O 64-bit x86_64 executable, flags:<NOUNDEFS|DYLDLINK|TWOLEVEL>

That’s a Mach-O binary, which is Apple not Unix. I’ve no idea how to run executables on macOS though, so :man_shrugging:

Thanks Nummer378. Perhaps someone else can provide guidance? Running/opening the Syncthing v.1.8 “Unix executable” just produces an error. See this screengrab:

(The syncthing app you see in the upper left of my screengrab is v.1.27 and will not run on my iMac.)

A quick search of the error message shown suggests that this may be caused by Apple flagging the binary (because it was downloaded from the internet, and the signature of the binary is most likely outdated so not recognized by your machine). It may have “quarantined” the app so you can’t run it. Removing the quarantine flag may solve this, according to my search results:

Wow, okay, I could have looked that up… I tried it, thank you. After giving that command to remove the quarantine attribute, I was able to launch the syncthing v.1.8 unix executable. The result: it invoked a terminal window with some kind of log. It did a lot of stuff from the looks of the log. One thing it did very early on, was to check version number, and then it updated the version to 1.27 (which is something I need to avoid).

After that the log shows some other activity, none of which makes sense to me. In the end it says [process completed]. Okay, but I don’t see anything running… no application is evident. I hope I’m not worse off than before (after all that terminal activity)!

I’m attaching the terminal file/log if anyone is curious about this issue:

240306-syncthing-Terminal-Saved-Output.txt (8.2 KB)

Yes, syncthing by itself always launches a terminal where it logs to. On some platforms you can launch it with the --no-console command line option to hide it.(PS: This is apparently only supported on Windows, nevermind)

The official builds have the auto upgrader enabled by default, yes. You can launch syncthing with the STNOUPGRADE environment variable set, or alternatively with the --no-upgrade command line flag to disable upgrades temporarily. Once started, you can also turn off auto upgrades from within the GUI.

After syncthing upgraded itself, it also restarted itself to apply the upgrade. The new version immediatly crashed - the log lines are crash logs from the OS/go runtime showing debug information. Since the updated syncthing release doesn’t support your macOS, the crash is to be expected.

1 Like

Nummer378: thank you that worked, after some trial and error for this inexperienced user. For those unfamiliar with the OSX command line, I summarize what I’ve learned below:

Remove the attribute and you can launch the application. To do this, open a console and type: $ xattr -c <path/to/>

To obtain “path/to/” just drag & drop the executable into the console window after typing in the command *xattr -c *(note the trailing space here), so the command will look like this:

$ xattr -c /Applications/syncthing-macos-amd64-v1.8.0/syncthing


The official builds have the auto upgrader enabled by default, yes. You can launch syncthing with the STNOUPGRADE environment variable set… Syncthing — Syncthing documentation

Here you set the environment variable with STNOUPGRADE=1 preceding the path to the executable. (again, you can easily get the path to the executable by simply drag&drop the executable icon into the console window) Submit / enter this in the command line, and this will launch the app:

$ STNOUPGRADE=1 /Applications/syncthing-macos-amd64-v1.8.0/syncthing

The app will launch, will not check for updates, will not update, will appear in the Menu bar, and a tab will open in your default browser, for settings etc. The settings already indicate that automatic updates will not be pursued.

Thanks again!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.