Syncthing on laptop does not see server

I have a setup with 3 devices: one desktop and one server that are both on the same network, and a laptop that is usually in a different network. I have a 3-way sync setup between the 3 devices. The server is supposed to be always on, which allows to keep the desktop and laptop in sync, even if they are not on at the same time.

I originally setup everything on the same network at home, and then brought the laptop to a different network. I dont have port forwarding. Everything was working well, until the power in my home went out and the server turned off. After turning it back on, my desktop and server could see each other in syncthing. However, the laptop does not see the server. Both devices show up as “disconnected” even thought the server is on.

How to fix it?

Seeing as how your home PC and your server communicate with each other as expected, we must suggest that Syncthing on the server runs correctly. Seeing as your laptop was (presumably) not affected by the blackout, I assume Syncthing is (still) running normally on the laptop, too. Now it’s just the question of communication between your server on your home network and your laptop on the other network.

Most homesteads nowadays come with a dynamic IP address, and it’s not uncommon for this IP address to change when router reconnects to the ISP after the blackout. It might take relay servers and your laptop some time to get to know the new IP address of your home network (where your server can be reached), but it shouldn’t take that much time (if, of course, you didn’t switch off relaying and didn’t manually set up the now-invalid IP addresses in the settings).

That is, assuming your home network is still connected to the Internet after the blackout.

I suggest you search the forum, there were prior threads debugging similar situations which might hold the answer to your problem.

Have you checked the logs for anything obvious like being unable to connect to relays etc?

If you still can’t find the answer, please post screenshots.

Home network is connected to internet obviously. Relaying is enabled (I did not change any settings) and I did not set manual ip.

I tried searching the forum but did not find the answer. Is there a thread in particular I should be looking at?

Here is a log from the laptop:

2020-01-21 14:16:03 Single thread SHA256 performance is 245 MB/s using minio/sha256-simd (225 MB/s using crypto/sha256).
2020-01-21 14:16:03 Hashing performance is 214.01 MB/s
2020-01-21 14:16:03 Overall send rate is unlimited, receive rate is unlimited
2020-01-21 14:16:03 Using discovery server
2020-01-21 14:16:03 Using discovery server
2020-01-21 14:16:03 Using discovery server
2020-01-21 14:16:03 QUIC listener ([::]:22000) starting
2020-01-21 14:16:03 Ready to synchronize "books" (2ql4s-gry5y) (sendreceive)
2020-01-21 14:16:03 TCP listener ([::]:22000) starting
2020-01-21 14:16:03 ...
2020-01-21 14:16:03 Ready to synchronize "research" (6ycvj-i9icy) (sendreceive)
2020-01-21 14:16:03 Relay listener (dynamic+ starting
2020-01-21 14:16:03 Ready to synchronize "Joplin" (efszz-crptm) (sendreceive)
2020-01-21 14:16:03 GUI and API listening on
2020-01-21 14:16:03 Access the GUI via the following URL:
2020-01-21 14:16:03 My name is "ron-XPS-13-9343"
2020-01-21 14:16:03 Device Q3MGNHH-VS7KJRW-24BSSEF-M7RU3NW-OSD3P6L-2RR3736-NIJ6ZHP-5LUHOAV is "ron-Z87X-UD3H" at [dynamic]
2020-01-21 14:16:03 Device 5TH46DN-INTHSXE-5APWOAA-MAXFTYO-HXEWKTF-GBHR5TJ-BF2HO3R-NF4WFA7 is "dino" at [dynamic]
2020-01-21 14:16:03 Completed initial scan of sendreceive folder "Joplin" (efszz-crptm)
2020-01-21 14:16:04 Completed initial scan of sendreceive folder "books" (2ql4s-gry5y)
2020-01-21 14:16:04 quic:// detected NAT type: Full cone NAT
2020-01-21 14:16:04 quic:// resolved external address quic:// (via
2020-01-21 14:16:13 Detected 0 NAT services
2020-01-21 14:16:33 Joined relay relay://
2020-01-21 14:16:41 Completed initial scan of sendreceive folder "research" (6ycvj-i9icy)

The UI should show the addresses it sees for those devices.

As I said, screenshots would probably be helpful.

Here is an image from laptop. Dino is the server.

Do you have a screenshot from another device?

What exactly are you looking for? As I explained in the first message, the other devices also dont see the laptop. It shows up as disconnected.

I brought the laptop home, connected it to network, and syncthing immediately starting syncing. Address now shows the local ip address

Here is a screen shot from another device, with Syncthing turned off on laptop (as explained in previous message, now that it is on same network, it works)

I am essentially interested what addresses each side sees when they are not connected and not on the same network. So far I’ve only seen one side of that.

1 Like

AudriusButkevicius, OK I understand now. Ill try to get you this picture. It is a bit difficult because it require me being home, but laptop being on at another location.

Weirdly enough, I am now back in the other network, and the laptop again cannot connect to server.

Perhaps that other network requires proxy configuration to connect out in general.

Does it mean that I would not be able to access internet in general if it were the case?

Depends on how the machine is configured.

Windows/browser proxy settings and syncthing’s proxy settings are different things.

I have Ubuntu 19.10. I connect to Wifi. I didnt not change any configurations. I can connect to internet via every app I have tried so far.

Sure, but the fact it works outside of that network implies the issue is local to that network, which will either be your machine configuration inside of that network or the network itself.

If you use a proxy in that network, then you’d have to tell syncthing to use that proxy as well.

Knowing whether you use or not use a proxy on your machine on that network is not really a syncthing question, nor do I really know how ubuntu does proxy auto-detection.

Also, I can’t really tell you if it has a firewall.

You can set STTRACE=connections environment variable which will tell you more what it’s doing and where it’s connecting, but that won’t explain whether you need to setup a proxy or disable some firewall.


I am now at home. I left the laptop turned on at the other network. From the desktop PC, I can see the laptop online, as shown in the picture below:

From the server (dino) I cannot see the laptop, as shown in the image below:

To remind what I explained in my original messages: when all 3 devices are in the home network, they all see each other. Everything was working fine before the power blackout. This problem I am now having only appeared after the server unexpectedly shutdown.

That one screenshot was all that’s needed, the laptop would not even have had to be outside your network:
In the “This Device” section the “Discovery” status is 2/5. Given the global ip of the laptop isn’t listed, it’s most likely the global ones that aren’t running. Press on the 2/5 to get more info about that.

This is what it shows:

What should I do with it?

It switched to 3/5, so I think that means at least one global discovery is working, i.e. that shouldn’t be a problem anymore.

What’s weird though is the first failure: the discovery-v4.syncthing... shows an ipv6 address - I don’t get that. @AudriusButkevicius @calmh ?