Syncthing on Google TV no longer working

I used Syncthing on Google TV and it worked well. Now, however, it asked for new permissions. Google TV then gives the error message that permissions to access the entire filesystem cannot be granted.

Any advice what I could do?

What happens if you don’t grant the permission? Does Syncthing simply close or is it stuck at the permission request screen? If that’s the case though, then you’re probably out of luck. The best bet would be to downgrade to an older version, at least for the time being.

You could also try reporting the issue at https://github.com/syncthing/syncthing-android/issues, but please include at least specific version numbers (for both Syncthing and the OS), and also a few screenshots/pictures showing the problem at hand.

2 Likes

Hi, This worked for me. Your mileage may vary. Go to Settings=> Apps=> Syncthing=> Permissions=> Files and Media=> Allow all the time.

After I did this, the grant permissions screen did not show up again and syncthing started working again after the Android 12 update.

I hope this helps.

2 Likes

Thank you so much… This worked perfectly. Syncthing running again!!!

1 Like

You are welcome.