Syncthing on Asustor NAS - Slow speed on local network

I have installed Syncthing on my ASUSTOR NAS and I am getting pretty low transfer speed. Further more, my Syncthing client shows the connection type as “Relay” and the ip address points to somewhere in the United States. What’s up with that? Is my local data getting routed through some US server? Sounds pretty problematic to me since all I want is to transfer files in my local network between devices. Could somebody help me to fix this transfer speed and potentially big security and privacy issue.


How did you install Syncthing?


I installed Syncthing from the ASUSTOR App Central.

I think I managed to solve my issue. I disabled “Relaying” from the Syncthing settings. Then I enabled syncthing ports on my client devices. Since my client devices are using ufw for firewall, this was as simple as running sudo ufw allow syncthing on both client devices.

1 Like

Nice to see that the problem is solved!

FYI 1: Disabling “Relaying” is NOT what solved it, because relaying is only used when direct local connection fails. In your case local connection apparently failed because of firewalls on the other devices.

FYI 2: Further, relaying is NOT a “potentially big security and privacy issue”. Not in my opinion anyway. ALL communication between Syncthing devices is ALWAYS encrypted, regardless of connection type.

Good night! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.