Syncthing no longer working on Google Nexus Player


(WyrdWyrd) #1

I happen to own two of the now discontinued Google Nexus Players. I guess they’re similar to Android TV?

Anyway, up until the most recent version of Syncthing, it worked on these devices. You needed a mouse for part of the setup, but that was all. You could use the app once it was setup without a mouse, although there was no way to dismiss the popup that asked about reporting usage statistics.

However, as of the most recent update, I am no longer to use syncthing on either of my Nexus Players.

When I try to start the app, it hangs on the loading folders screen. After about a minute or so, Syncthing notices it’s taking a while to respond and suggests looking at the log. That works sort of. But the log just has the start of one line at the top nothing else.

Since then, I’ve tried reinstalling Syncthing. But now, after choosing “Allow” in the permissions popup, it hangs on the “Generating keys” screen. I mean–I could wait for the “several minutes” it suggests, but I’m pretty sure I’ll be waiting for infinity.

Btw these are not rooted devices, these are running vanilla Android version 8.0.0.


(Audrius Butkevicius) #2

There is a known issue with syncthing not working on some devices due to seccomp filters. This should be addressed next release.


(WyrdWyrd) #3

I am pleased to report that as of the v0.14.46 update, Syncthing is once again working on Google Nexus Player.