Syncthing never syncs on FreeNAS with 100% CPU usage

Running FreeNAS 9.10.1 (FreeBSD 10.3) with the ‘official’ syncthing plugin. The plugin is still at 0.14.3 but it autoupdated itself to 0.14.17. I’m trying to sync from a Windows 10 PC. It has never worked. The first shared folder never completes. It stays at 0% sync and the syncthing process is pegged at 100% processor usage on the NAS. It has been going for about a half hour now with only 346 files.

It’s obviously stuck in some kind of infinite loop. This is my first experience with Syncthing. Very disappointed.

Try using the releasefrom github. Number of files doesn’t really matter, total size of files matters more. Syncthing needs to hash the files using a crypigraphic hash to track their content, and if you have a lot of data and a weak cpu, it can take a while.

It’s 2.08 GB (not huge) and it’s a Xeon server (not weak).

If I look at the target directory on the NAS, everything is there and apparently in the correct size, however they are all renamed to .tmp.

As far as I can tell, it has not stored any logs anywhere. It reports no errors in the webGUI.

It updated itself to this version automatically and without asking me. It should work. If it requires downloads from github, then this solution just isn’t for me.

It logs stuff to stdout, so probably you have tons of errors there.

Puller (folder "xxxxx-xxxxx", file "Photo/IMAG0594.jpg"): dst create chmod: chmod /mnt/Documents/doom/Desktop/Photo/.syncthing.IMAG0594.jpg.tmp: operation not permitted

Error messages like that, over and over.

It’s very strange. The *.tmp files are owned by the syncthing user account, and when I run it as root, I still see the error messages. What chmod command is it trying to run?

You probably have ACL issues.

1 Like

Perhaps. I just set “Ignore permissions” and was able to get it to work.

It seems to me that this should be considered a bug. The interface gave no indication that there was a problem setting permissions on the filesystem. It seems the software was perfectly happy to simply retry the operations forever while leaving progress at 0% and using one of my cores at max capacity. There should have been a failure or an error message in the webGUI.


Its a bug with whoever provides the plugin with wrong ACLs. The UI does show an error saying its not making any progress, check the logs.

I respectfully disagree. The bug is not that there were permission issues. The bug is that a permission issue was not reported to the user as a failure. I know that if it can’t create the files in the first place it will report a failure, however apparently the chmod does not.

Reported as #3865

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.