Syncthing instances do not find each other on the local network when global discovery is disabled

Syncthing is not found when global discovery is disabled It seems that my syncthing on the laptop doesn’t find my syncthing on the computer if the global find is switched off for laptop syncthing. The port is the same for both. Both machines are running Linux Mint and Syncthing GTK and they are on the same network and the port is the same. If global discovery is turned on, this is not a problem.

Your machine or router probably filters out multicasts/broadcasts which we use for discovery.

Also make sure they are in the same subnet (with the same subnet mask) as that decides where the broadcasts are sent.


Thanks for the tip. It was the firewall turned on in Linux Mint. Now I enabled port 21027 in the firewall and now it works.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.