Syncthing hangs at 'Signal 15 received; exiting'

So I have syncthing (v1.20.3) running on a windows 10 machine.

At some point one of the folders to be synched becomes unmounted and syncthing complains about the missing folder. So I mount the folder again but still no luck. I tried to restart syncthing and the last log line is ‘Signal 15 received; exiting’.

I tried to close the cmd window with no luck. Tried to kill the process in task manager and got “access denied”. Tried some pskill tool, or the builtin taskill with no luck.

Even trying to reboot the computer failed. I had to do a hard reset.

Suggestions on how to solve this?

More details will probably be required here to be able to say what is going on. It appears that the Syncthing process gets stalled at some point, and then it fails to recover.

How have you installed Syncthing specifically? Does “mounting” here mean that you mount a partition in an empty folder on yet another partition? What does “unmounting” mean exactly?

I just unzipped the package and ran the syncthing.exe process directly. It has been working perfectly for more than a year.

With respect to my mounted files actually I’m using cppcryptfs to mount a drive letter. On that drive are a few folders which are defined as folders to share in syncthing. For some reason cppcryptfs failed and unmounted.

Any logs I can look at to investigate?

More info from the logs (I obfuscated with question marks the info I thought was sensitive). These are the last lines,

[BAK23] 2022/07/28 14:24:39 WARNING: Error on folder “Personal” (???): folder path missing [BAK23] 2022/07/28 15:07:21 INFO: QUIC listener ([::]:22000) shutting down [BAK23] 2022/07/28 15:07:21 INFO: Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down [BAK23] 2022/07/28 15:07:21 INFO: Connection to ??? at ???/tcp-client/TLS1.3-TLS_AES_128_GCM_SHA256 closed: Syncthing is being stopped [BAK23] 2022/07/28 15:07:21 INFO: Connection to ??? at ???/relay-client/TLS1.3-TLS_AES_128_GCM_SHA256 closed: Syncthing is being stopped [BAK23] 2022/07/28 15:07:21 INFO: TCP listener ([::]:22000) shutting down

Yeah, so that’s definitely non-standard. Normally, when you talk about mounting drives in the Windows context, it’s https://docs.microsoft.com//windows-server/storage/disk-management/assign-a-mount-point-folder-path-to-a-drive.

The situation here is something completely different though. You said you’d been running Syncthing for over a year, but what about cppcryptfs? Has it also been used together with Syncthing for that long?

I’ve got no experience with cppcryptfs, so I can’t provide any concrete help in relation to it, but for me this seems to be a problem with the cppcryptfs driver and its communication with the OS rather than something specific to Syncthing.

Yes this setup, using cppcryptfs, has been stable for over a year without issues.

The only recent change, as of this morning, is a whole bunch of pictures I put in a folder (a normal one, not under cppcryptfs) and these get synchronized to another machine.

So I’m currently copying the files from the mounted drive to a physical disk and will change the path for the synced folders before restarting syncthing. I’ll report the result.

For what it’s worth, if the process can’t be killed and the system doesn’t shut down cleanly, I don’t think it’s Syncthing blocking the shutdown. If it was just Syncthing, Windows would happily kill the process. Rather, the disk/mount/whatever not responding is blocking Syncthing and the rest of the system, preventing shutdown.

So after I copied the files from my mounted drive to a physical disk I was able to complete the synchronization. However shortly after the whole computer froze. Looks like a hardware/driver issue that just suddenly happened.