syncthing-gtk not starting

Yesterday the ppa containing Syncthing-gtk for Ubuntu updated to version 0.9.3. Since then it doesn’t launch at all. In the terminal I get the following error:

Gtk-Message: Failed to load module "unity-gtk-module"
I StatusIcon    Using backend StatusIconGTK3 (primary)
I App           
I App           Syncthing-GTK started and running in notification area
/usr/lib/python2.7/dist-packages/syncthing_gtk/ PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3 as appindicator
W StatusIcon    StatusIcon: Using backend StatusIconAppIndicator (fallback)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/syncthing_gtk/", line 398, in _request_config
	RESTRequest(self, "system/config", self._syncthing_cb_config, self._syncthing_cb_config_error).start()
  File "/usr/lib/python2.7/dist-packages/syncthing_gtk/", line 1045, in init
	self.connect("event", self._socket_event)
TypeError: argument connectable: Expected Gio.SocketConnectable, but got unicode

In the system tray icon it just says “Connecting to daemon” and never connects.

Clicking “Show Window” just shows a plain window as shown below

I have this installed on two machines running Ubuntu 17.10 and neither work.

Windows here and 0.9.3 did the same. When I checked with ProcessExplorer I could see that syncthing was constantly started by Syncthing-GTK, then it exits and is started again. I tried a clean install of Syncthing-GTK 0.9.3 but that did not help. Then a clean install of worked as expected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.