Syncthing GTK fails downloading binarys

@kozec Syncthing GTK fails when downloading the syncthing binary on a first start on a fresh Linux Mint KDE Mate System … It is simply not downloaded and the progress bar is not moving farther.

I have installed Syncthing GTK from here

Try to run it with syncthing-gtk -d from console and check if it outputs any error. Or just upload log somewhere.

Not working download may be caused by pretty-much anything from github being down to your local proxy setting trying to route it throught antivirus…

I solved it another way. I downloaded and installed the syncthing binary myself, after that Syncthing GTK recognized it. After that I was able to continue the setup process

I observed the Syncthing GTK When installing on Linux Mint cinamon or Linux Mint KDE Mate, behaves differently. On both operating systems I installed Syncthing GTK from a deb package. In Linux Mint Cinamon everything worked smoothly. Syncthing was downloaded in the “/home/rick/.local/bin/” On the MATE KDE setup of Syncthing GTK has not worked, the download of the syncthing binary did not start. I had to install it manually. These happened in the read-only “/ usr / bin” folder. This prevented the automatic update of Syncthing. At least I was able to continue the setup process of Sncthing GTK. Then I copied the Syncthing binary from the “/ usr / bin” folder in a writable folder and in Syncthing GTK I changed the path.

Perhaps it is because, on Linux Mint Cinamon a 64-bit version runs.

Read-only /usr/bin shouldn’t be problem, ST-GTK is not going to write there anyway. But on KDE-based distro, there is chance of having some library missing.

Having log or knowing what exactly “MATE KDE setup” is would help…

I men if ST GTK is making his first setup on Linux Mint Mate KDE Edition