syncthing from windows to linux

Today I have setup syncthing from windows to linux and on windows I have “syncing (0%, 35Gib)” and nothing happends. And it is verison 1.2

2019-07-09 12:00:32 Device ZJ7BNL-BOVQB-P7F7D2-5N7IKR-OI54U-VPDVP3-EVWES2-ECEDQK client is "syncthing v1.1.4" named "" at
2019-07-09 12:00:32 Unexpected folder "Zadruga" (7wd9e-xbxgv) sent from device "ZJ7NL-BOVBP-P7GF2-5NIKR-OIF4U-VPVP3-EVES2-ECDQK"; ensure that the folder exists and that this device is selected under "Share With" in the folder configuration.
2019-07-09 12:05:43 Connection to ZJ7NL-BODQB-P7FD2-5NYIK-OINFU-VLDV3-EWWS2-ECEDK at closed: reading length: read tcp>182.19.512.19:22000: wsarecv: An existing connection was forcibly closed by the remote host.
2019-07-09 12:06:34 Established secure connection to ZJ7BN-BOVQP-P7FD2-5N7IR-OI5FU-VPDP3-EVWE2-ECZDK at
2019-07-09 12:06:34 Device ZJKNL-BOVBP-P7FD2-5NYIR-OINFU-VLDP3-EVES2-ECZQK client is "syncthing v1.1.4" named "" at
2019-07-09 12:06:34 Ignoring folder "Zadruga" (7wd9e-xbxgv) from device Z7BNL-BDVBP-PGFD2-5Y7KR-ON54U-VPDP3-EWWS2-ECZDK since we are configured to

On linux I have “up to date” and it is version 1.1.4 ID is not real

2019-07-09 12:05:33 Detected 1 NAT service
2019-07-09 12:06:00 Established secure connection to 53AEC5-VT5QU7-FQ7Y3W-E7HB37-FGD56X-BQBG5Y-5SXMZ3-IGPQA5 at
2019-07-09 12:06:00 Device 53E2C5-VT4QU7-F7YLW-E7HX7-FGS6X-BQB5Y-5S5Z3-YIPQA5 client is "syncthing v1.2.0" named "SQLSZ" at
2019-07-09 12:06:01 Ignoring folder "Arhiv SQL" (txnyp-zhlmo) from device 53AC5-VT5QU7-FQ7LW-E73X7-FGDS6X-BQ3G5Y-5XMZ3-YIGQA5 since we are configured to
2019-07-09 12:07:56 Joined relay relay://

The only things those logs tell is that you have folders which you ignored - maybe intentionally, maybe not, but it doesn’t seem related to the problem you describe.

Please make screenshots on both sides and post those.


Ok, so the logs are relevant: Zadruga and Arhiv SQL respectively are shared with the other device, but you also ignored that folder on the other device. You find ignored folders in actions->settings->ignored folders to unignore them.

No this doesnn’t work. I try on windows computer when syncthing suggest to add new folder I change path to D:\imagine_zipano_arhiv and than add.

on linux computer when syncthing want me to add folder I also change path to /arhiv/zadruga/imagine_sql/sync

But after that sync thing want me again to add new folder with his own path. I just cant synchronise two folders with my path

So? Add it. If these are the same folders (i.e. you only want to share on folder), then remove the existing folder on one site and click on Add to start sharing it - you can choose any path of your liking.

that is the point I can not. eveyr time I do, syncthing want me to add new folder in it. It alows only to be synchronised from windows computer folder A to linux computer to folder B and from linux computer folder A to windows computer to folder B but it is not possible to syncronise from windows computer folder A to linux cimputer folder A

it goes A->B B->A but not A<->A

and what I really want is to copy only files from windows A to linux A. other way not

Ok, lets try it like this:

  1. Remove all folders you have now.
  2. Add the folder you want to sync on windows, choose folder type send-only and share with the linux device.
  3. Wait until the “New Folder” prompt appears on linux and click “Add”.
  4. Enter the path to the directory you want to sync to.


I did that and nothing is going on.

It’s indeed a bit weird that your transfer rates are (almost) 0, but that might be incorrect (there’s some problem I think with bursty limits or whatever). Anyway with a limit of 500KiB/s transferring a file of 34.5GiB will take roughly 20h. And there’s a bug that’s fixed in the next release (v1.2.1 probably), because of that you need to open the list of out of sync items to see progress. In short: Give it a moment and then check again whether anything happened or not (or preferentially: Use another mode of transport for so much data if you have so little bandwidth).

ok what I did is update linux version to 1.2 restart all and it started to upload for a fev seconds and than stopped again. It doesn’t matter how long it will upload file. But I have deleted that 500Kib and set to 0 as default but still nothing.

don’t know what happend but after 30 minutes it start to upload file!

Again stuck on 43% and doesn’t move for 10 hours now.

Screenshots please from both sides.

It looks like it work and than stop and than work again now it is on 52%

I suspect you are just running on some weak powered device and it’s just struggling. I suggest you look at the system metrics, such as disk latency, cpu and memory usage

I think here is more problem bandwidth because it is 20 Mbps download and 4 Mbps upload.

I already wrote before that sync percentage is not updating for a single file. That will be fixed in v1.2.1. Reloading the UI will update the percentage. So everything is good, just have some patience.

It is just one file 35GB