Syncthing fails to start after reverting Windows

Hi all,

I recently had a separate piece of software go haywire, so I reverted my version of Windows back 2 days. This successfully fixed the other software, but now SyncTrayzor will not load. On bootup, it displays this error message:

Failed to start Syncthing.

Please read the log to determine the cause. 

If "FATAL: Cannot open database" appears, please close any other open instances of Syncthing. If SyncTrayzor crashed previously, there may still be zombine Syncthing processes alive. Please use the menu option "Syncthing -> Kill all Syncthing processes" so stop them, then use "Syncthing -> Start" to start Syncthing again.

I’ve tried clicking the “Kill all Syncthing processes” button, but there are no processes to kill. I’ve tried uninstalling and reinstalling SyncTrayzor. I’ve also tried uninstalling SyncTrazyor, removing all instances of SyncTrayzor and Syncthing in the registry, and reinstalling SyncTrayzor, to no avail. Syncthing standalone loads just fine. When I try to start SyncTrayzor and it loads the above error message box, the log displays this:

[NFZY4] 23:22:33 INFO: syncthing v1.2.0 "Fermium Flea" (go1.12.6 windows-amd64) teamcity@build.syncthing.net 2019-06-28 06:03:29 UTC
[NFZY4] 23:22:33 INFO: My ID: NFZY4RB
[NFZY4] 23:22:34 INFO: Single thread SHA256 performance is 359 MB/s using minio/sha256-simd (292 MB/s using crypto/sha256).
[NFZY4] 23:22:34 WARNING: Failed to initialize config: Config file version (32) is newer than supported version (29). If this is expected, use -allow-newer-config to override.

Does anyone have any ideas of how I can get SyncTrayzor to load back up again?

It looks like when you reverted Windows it also reverted syncthing to an earlier version. Try installing the version you had installed previously or upgrade to the latest version and that should resolve the issue.

The error is simply saying the config file format is newer than the version of syncthing you are running.

2 Likes

I’ve been using the same version since I downloaded it, to my knowledge. 1.1.24 came out on Jul 27, 2019, and I haven’t been using it that long. Maybe I need to delete the config file? Even after a full uninstall, something must be left over that’s confusing SyncTrayzor/Syncthing.

That’s the synctrayzor version. It wraps the actual Syncthing binary, which updates itself. Grab the Syncthing from https://syncthing.net/downloads/ and replace the one used by synctrayzor (which should be at C:\Users\<You>\AppData\Roaming\SyncTrayzor\syncthing.exe).

1 Like

And just in case you cannot find the AppData folder (as it is hidden by default), copy and paste %APPDATA%\SyncTrayzor into the address bar in Windows Explorer, and press Enter.

It looks like that did it! Thank you all very much.