Syncthing Error "The application can’t be opened." -50

I use Syncthing on macOS 14.4.1 (Sonora)

The Syncthing Service is running (as I can see in the top bar), the API is not. If I want to “Open Syncthing Web Interface” (button in App window) or press “Preferences” or “Open” in the Syncthing Menu I get the Error

The application can’t be opened.
 -50

I tried to re-install Syncthing by deleting ~/Library/Application\ Support/Syncthing/ and deleting the app, but when I re-install it somehow is still the same

What am I doing wrong?

The tray/toolbar widget/app is separate from Syncthing itself, so try accessing Syncthing’s web GUI directly: http://127.0.0.1:8384/

If that works, then the issue is with the wrapper app. Could be security software blocking it or it could be permissions issues.

1 Like

Thank you very much! Access via http://127.0.0.1:8384/ works (but not if you enter it in the wrapper app :wink: )

I imagine it’s a permission issue, but since I know that the web GUI works, I’m good.

Thanks again @gadget , this really helped!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.