Syncthing enforces speed limit even in LAN

I have set up Synthing (v1.15.1, Linux (32-bit ARM)) on my Raspberry Pi 3B+. I have two android devices that sync the data to my syncthing server locally and globally. The Syncthing is bound to and I access the Web GUI via NGINX reverse proxy.

I have set up speed limits for global transfers to 100KiB/s for both devices for upload and download. Also, I made sure that the “Limit Bandwidth in LAN” option is disabled in Advanced configuration. However, I have noticed that this speed limit is followed for both LAN transfers and non-LAN transfers.

Why is Synchting identifying even the LAN connections as non-LAN connections?

Edit: I forgot to mention another thing. I changed the Syncthing address from to, and the proper functionality was restored. However, I would still be interested in knowing the cause for this behaviour.

I suspect the cap in speed is happening due to weak hardware, not due to options selected. What remote device ip addresses are reported in the logs as they connect?

I don’t think that the cap is due to the hardware because it starts working immediately as soon as I set synchting address to However, I will check the logs and send them to you soon

This occurs on Windows nodes for me as well, did not test Linux nodes. Also, interestingly, each tested Windows node has a custom Sync Protocol Listen Addresses and is using a custom port.

@gopaljigaur are you using a a custom Sync Protocol Listen Addresses?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.