Syncthing Created Lots of syncthing-enc folders

I’m brand new to syncthing. It’s working between two devices, but when I try to add a third and a fourth using the same shared folder, it creates a series of ‘syncthing-enc’ folders in the shared folder. All devices are set up to accept encrypted data. Everything else is working fine. To set up the additional devices, I’ve been first connecting the new device to the existing device that has the shared folder with information. Once I confirmed that the devices are connected, I set up the sharing on the original device that has the data. The new device doesn’t have any info in the shared folder. Syncing starts immediately, but, as I said, the new device contains multiple folders with name ‘syncthing-enc’ and subfolders named with numbers and letters. Each folder appears to have key in it.

I’ve tried on Linux and Windows machines and got same results.

Would appreciate any advice on what I’m doing wrong.

Hi! Please read: You have configured the new devices as “untrusted”, which means that they do not get the original files, but encrypted versions of the files. This is something I would use if I, for example, set up a synching instance on a machine in a Colo or friend.


Thanks. That solved it. It’s still somewhat confusing to me. I thought if I set passwords on all the shared folders that would be ok, but looks like it’s just the opposite unless you make the device untrusted in the advanced settings. Does that make sense?

I’m new to this forum. Is there a way to mark this solved?

Appreciate your help.

Setting a password means that the other end is untrusted.

There is no way of closing. A topic is automatically closed after a month, I think.

You can select a reply as solving the issue, which makes it easier for others.

Hope you enjoy Synching as much as I do! Welcome back in case you wonder about something else.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.