Syncthing Crashing and Getting Panic Log

When ever i run syncthing it opens for a minute then crashing creating a file called panic-20200707-223328.reported.log.

It should print the panic explaining the crash reason (as well as store it in the log)

it says Panic at 2020-07-07T22:33:28-05:00 panic: device present in global list but missing as device/fileinfo entry how would i fix that

Take a backup of your data (or set it to send only next time you add the folder), and reset the database (via -reset-database command line switch or by deleting the index directory from syncthings config dir).

thanks alot it worked but can you explain to me why exactly the error occured??

For the record: The db check/repair should fix this defect, i.e. running with STRECHECKDBEVERY=1s should thus be enough and is less risky and requires less resources.

Why it happens I’d like to know too, no idea unfortunately.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.