Syncthing completely bypassing VPN when syncing

Hi all, new user here. I just downloaded Syncthing and am having a minor issue. I’m using the SyncTrazer GUI on my Windows 10 desktop. I also use a VPN (ProtonVPN) on the same machine, which is always running. I noticed that none of the syncing traffic is going through my VPN. What might be going on here? How can I ensure that it only goes through the VPN? Thanks!

Hi there, while I am only a new Syncthing user, I am a IT guy who does a fair bit of networking. I have no knowledge of ProtonVPN, but most VPNs offer a fair few features and functionality. One of those features, or modes, is something called Split Tunnel. What that means is some traffic goes through the tunnel, and some does not. So IMO this is very likely not a Syncthing issue but a VPN issue, and specifically a routing issue. Meaning your computer has a routing table, containing routes, some routes ‘point’ to the VPN tunnel, and other routes, likely just the one default route in many cases, ‘bypasses’ or ‘ignores’ the VPN tunnel.

1 Like

I have split tunneling turned off, but you’re probably right that the issue does not lie specifically Syncthing. Lacking much networking experience, I’m not sure how I would ensure that Syncthing is pointing to the VPN tunnel

You don’t point Syncthing to the VPN tunnel. You point destination routes to the VPN tunnel. If spit tunnel is turned off then all traffic should go through the tunnel, but not knowing the ProtonVPN configuration, your OS behaviors and its configuration, etc, etc, etc, its hard for me to say what is, or could be, the cause. On your computer try to open a command line window and try to view its routing table. On a FreeBSD node it sort of looks like this: $ netstat -r Routing tables

Internet: Destination Gateway Flags Netif Expire default router UGS igb0 192.168.2.0/24 link#1 U igb0 192.168.2.101 link#1 UHS lo0 localhost link#2 UH lo0

You should see all routes using the VPN interface, except likely a special route so that the VPN tunnel itself will use your interface. As I don’t know if the ProtonVPN software does that automatically, or if you have to configure it via the software, or manually through the OS. And its conceivable another program is also mucking with your routing table. All depends on your set up.

1 Like

Appreciate the help! After looking at the routing table, it seems that there are many addresses not going through the VPN. Not sure what the cause might be. I’ll look into more with my VPN provider. Thanks again!