Syncthing broke after upgrade to Ubuntu 18.04

I recently upgraded from 16.04 LTS to 18.04 LTS and Syncthing seems to have got broken in the process. I have a syncthing-resume.service but no other associated service. Any ideas?

Thanks!

Uninstall and reinstall it I guess. I have no idea what the cause is, perhaps there is something in the upgrade logs, but it’s not really a syncthing issue but an Ubuntu issue.

Is there way to do that and preserve all the folders? I guess by keeping the computer ID?

The config and keys that make up the id are stored in ~/.config/syncthing/, I suggest setting the remote side to be send only before you attempt these acrobatics, just in case something goes wrong.

1 Like

Ah-ha! After reinstalling and noticing it still doesn’t start on boot and the service is missing from the list (but not from the /etc/init directory), I think I’ve identified what happened.

Canonical discontinued upstart from Ubuntu 17.10 completely. Because my box was originally running 14.04 LTS, and then 16.04 LTS (where upstart was still supported), when I upgraded to 18.04, it simply started silently ignoring upstart scripts. :scream:

I tried following the instructions at https://docs.syncthing.net/users/autostart.html, but I’m going crosseyed trying to follow them, being completely used to upstart. I’ll keep plugging away…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.