Syncthing behind traefik gives Internal Server error

Hi there,

I’m running Syncthing in a LXC on a Proxmox server. I can access Syncthing by direct IP address. However when I use syncthing.example.com I get a InternalServer error. Other aps like apps-pihole.yml work just fine so I guess I’m something missing in my aps-syncthing.yml file.
This is my file…

http:
  routers:
    syncthing-rpi-rtr:
      rule: "Host(`syncthing.{{env "DOMAINNAME_CLOUD_SERVER"}}`)"
      entryPoints:
        - https
      middlewares:
        - chain-authelia
      service: syncthing-rpi-svc
      tls:
        certResolver: dns-cloudflare
   services:
    syncthing-rpi-svc:
      loadBalancer:
        servers:
          - url: "https://192.168.1.205:8384"  # or whatever your external host's IP:port is

can somebody help me find the missing parts?

Looks like you’re pointing Traefik to Syncthing over https. Does it accept the certificate?

What happens is that after I enter my credentials in a authelia I get a Internal Server error. How can I see that the certificate is accepted by Syncthing? portainer,traefik and Pihole show a closed lock in the browser. I have enabled https in the gui

Other way around; Traefik is talking HTTPS to Syncthing, and will attempt to validate its self signed certificate, which will probably fail. You probably want to disable https in Syncthing and use an http url in Traefik.

I just tried that and now I got a 404 it seems that even when I type a http://syncthing.example.com the certificate is accepted and the lock is closed.