Syncthing (Android) does not reactivate when "Run on specific WiFi networks" is enabled

I’m having trouble with the option “Run on specific WiFi networks” in Syncthing for Android (13).

Steps to reproduce:

  1. When connected to WiFi network, add it to the list of allowed networks

  2. Disable WiFi (Syncthing will be deactivated)

  3. Enable WiFi (Syncthing will not be activated until the Syncthing app is opened manually)

As long as the list of allowed networks is empty, I have no such problems. Syncthing will automatically start as soon as the WiFi connection is established.

Can somebody reproduce this behavior?

Please check if location services are enabled in the Android settings, and then also check in the app permissions whether Syncthing can use location all the time (and not only when the app is in use).


After allowing syncthing to always use location, everything works as expected.

Thank you!

1 Like

We should ask for that permission in the first run wizard of the app. The foreground permission doesn’t really cut it for our use case. I’ll look into it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.