Syncthing and MS Windows Server 2016, fatal error: winmm.dll not found


i’m trying to setup syncthing-windows-amd64-v1.4.2 on a fresh installation of MS Windows Server 2016. I’ve put the synchting folder under “C:\Program Files” and when i launch synchting.exe, i receive the follow error:

C:\Program Files\syncthing>syncthing.exe
fatal error: winmm.dll not found
runtime: panic before malloc heap initialized

runtime stack:
runtime.throw(0xe35b91, 0x13)
        C:/Go/src/runtime/panic.go:774 +0x79 fp=0x1aefd70 sp=0x1aefd40 pc=0x432df9
        C:/Go/src/runtime/os_windows.go:240 +0x747 fp=0x1aefed0 sp=0x1aefd70 pc=0x42ece7
        C:/Go/src/runtime/os_windows.go:414 +0x9e fp=0x1aeff30 sp=0x1aefed0 pc=0x42f19e
runtime.rt0_go(0x1aeff60, 0x7ffe4c6c8364, 0x1aeff60, 0x0, 0x7ffe4c6c8364, 0x0, 0x0, 0x0, 0x0, 0x0, ...)
        C:/Go/src/runtime/asm_amd64.s:213 +0x138 fp=0x1aeff38 sp=0x1aeff30 pc=0x45f1f8

C:\Program Files\syncthing>

Same error with the 32 bit version. Also older versions release same error. Obviously the winmm.dll file (mentioned in the error message) is present and isn’t damaged. I’ve tried also to recovery any possible files damaged of Windows Server 2016 installation by executing “sfc /scannow”, but all the system files are ok (and, thus, the problem persist). Any suggestions are appreciated.


Which antivirus do you have on the server?

Hello Catfriend1: thanks for your quick reply. Only Windows Defender, it’s a fresh installation…

Not sure, I don’t think it’s really a syncthing issue. Do other go programs work? Are you able to compile and run go programs yourself?

1.4.2 from our downloads works for me on my Server 2016. So it’s not systematic at least.

@AudriusButkevicius: I’ve already executed “sfc /scannow”, but with no success. And, yes, winmm.dll is in it’s correct place (C:\Windows\System32). No, i can’t compile a program, at this moment.

@calmh: Ok, this is a good thing…

What if you extracted the syncthing files say on the desktop rather in that in system folders. Would it run then?

I have St running on servers from 2008 - 2019 inc SBS 2011 without any issues and never had to put additional files anywhere else.

@terry, just now i’ve extracted it on a Desktop folder of a new user (without a lot of fantasy, user name “user”) in Administrators group and the error is the same.

how are you accessing the server - via remote desktop?

@uok: Yes!

Can you access the server directly? You know, old school, go over to server room, breathe the cold cooling air and use a real keyboard? :sunglasses:

My guess is there is something wrong with remote desktop client, the dll points to something with audio. Remote desktop can play sounds remotely

@uok: i’ve tried to access to the server directly with local keyboard/mouse and monitor, but nothing change… :open_mouth:

Has the server gone live? if not i would blow it away and start again. i once configured a server from scratch and it just wasn’t quite right, so I wiped and reinstalled and the issue wasn’t there after.

if you are getting errors, there is something wrong with the installation. was it an in-place upgrade?

@terry, it’s a fresh install, all work properly, no errors to report. The server is the DC of local test domain. If possible, for me is more convenient solve the error instead to proceed to an installation from scratch

How about a test VM server install and drop Syncthing on there. If you get the same error then you can trace the fault without causing too much ‘live server’ fiddling, but if St runs without issue, then it comes back to your server installation.

On a side note, I would not install St on a DC. If St crashes (and it does for me occasionally) then only a reboot will resolve it. Not good if you are on a DC. I have not yet successfully killed a crashed St, always get access is denied messages. Plus St can be both IO and ram intensive on occasions.

Ok, i think i’ve found the problem: the system’s hard disks probably are damaged or the hardware RAID controller have a problem. The OS was running in a couple of hard disk that compose one volume and configured in RAID1. I’ve find a lot of failed installation attempt of update packages, as well as syncthing that doesn’t work. Because of this, i’ve tried to reinstall the OS, but the setup process die with a files corruption errors or with a missed files errors. Thus, i’ve dismantled the RAID1 volume and i installed an SSD drive. Now all work properly… :slight_smile:


Try replacing the sata cables. Cheap / bad ones can have a huge effect on raid arrays

1 Like

As @terry stated above, please check your cables first before blaming the controller. In the past, I encountered a lot of issues caused by faulty SAS cables, and the controllers were mostly fine. I did have one instance, where the controller itself died, but that was an exception.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.