Syncthing ALWAYS conflicts

Hello After trying MANY things, I am at a standstill. The environment: 3 Syncthing instances. 2 on Windows 10 and one on Debian buster The issue: Syncthing throughs conflict messages ANYTIME I edit any of the shared files on any of the machines. I would like to know why and how to stop it from doing so. I share lists on all the machines and want to edit any of them on any of the machines and I AM THE ONLY PERSON USING THE SYSTEM and can only be at one of the machines at any point in time. Thank you all for the greate work you have done towareds this project!

Please provide screenshots showing the Syncthing Web GUI on all devices. Also, because Debian is involved, make sure that you’re using the newest version (see and not the old one that they provide by default.

What kind of conflicts are we talking about here? Have you tried comparing the conflicted files to see what exactly differs between them?

Also, is one of the instances a very old installation that potentially predates large blocks?

Hello Audrius and thank you for your answers I basically created a text file (simple.txt) in the shared folder on the first computer (Adel’s office). I then edited the file on a second machine (CC1) which immediately threw the conflicting message. The Debian machine is running v1.19.1, Linux (64-bit ARM). I have attached the screen shots from CC1 and Adels computer. Thanks!


Here is the Debian log when I tried to do an upgrade to Syncthing: debian log.txt (2.8 KB)

Is there some exotic filesystems involved?

Have you tried ignore permissions option?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.