Syncthing 1.20: 'remote device has not accepted sharing' - but no sharing offered

I’ve Syncthing 1.20 on $WindowsPC and $LinuxPc and a directory, $sharedDir, which is shared between the two computers.

The Windows PC shows sharedDir stuck syncing at 99%. There’s a footnote saying that ‘the remote device has not accepted sharing’. Yet, $sharedDir did show in $LinuxPc’s Syncthing UI. So I deleted $sharedDir from the folder list in $LinuxPc’s Syncthing UI. Then I reshared $sharedDir with $LinuxPc. No dice: $LinuxPc still shows no message about accepting the share; and $WindowsPC still shows syncing stuck at 99%.

Log from Windows. Log from Linux.

You can add the folder manually with the same id. Also, in options, check that the folder has not been ignored before.

Unfortunately the logs don’t tell anything useful. You could try with the verbose flag maybe. And please do tell us which folder and device it is you’re getting the not shared message for.

In fact, the Linux logs do mention one ignored folder. That’s a likely cause.

Thanks, both.

Let me add information.

  • It is on $WindowsPC that the GUI says that $LinuxPC is stuck syncing at 99%.
  • On $LinuxPC, the GUI displays no problem.
  • On $WindowsPC, no ‘folders’ are ignored.
  • On $LinuxPC, various folders are ignored, but none of them are on $LinuxPC itself, and some of them have as names alphanumeric spagetti that I do not recognise. [Edit: I acknowledge that the same could be said of my user-name for this forum!]

If an ignored folder is the cause of the problem, it would be good were this made more evident to the user. (I have long said that something that lets Syncthing down is the lack of information that it gives when something has gone wrong.)

I can supply verbose logs (by running Syncthing from commandline and with a special flag, yes?).

You can add the folder manually with the same id.

I do not understand why I would want to do that or how to do that. Please elaborate. Thank you.

I have been tossing around in my head the idea of a “troubleshooting center” within the GUI for some time now. Several kinds of problems, unexpected conditions and tips to make better use of Syncthing could be collected there. It’s not an easy task though and needs more planning, so no ETA on that.

Ignoring folder “Android (general)” (6cvwe-3vz40) from device GXDEVT7-O5RT2UN-KJEBZJG-HXDGOQQ-DO7AQD2-FL33D7G-ASJKOOB-NLMTTQM since we are configured to

This message in the Linux PC’s log caught my attention, but you still haven’t told which folder is actually marked as “not shared”. Make sure not to mix up ignore patterns (for paths within a shared folder) with ignored folders, e.g. sharing invitations that you have permanently declined at some point. For the latter, I see only that one mention, not “various” folders in the log.

If you start adding a new shared folder on $LinuxPC, you have a chance to override the randomly generated “Folder ID”. Just enter the one from your $WindowsPC in that field and make sure to select the device under the “Sharing” tab as well. The Folder ID is what connects the folders together, so if the notification banner does not appear (so you can accept the sharing offer), you can just as well enter the ID manually that way.

I’d just like to ask for screenshots of the Syncthing Web GUI from all affected devices. It’s often much easier to spot something wrong or suspicious using visual information :slightly_smiling_face:.

Well, why should we bother you again if you pressed ignore?

Thats specifically there to stop bothering you. Not sure if doing what the user asked us to do is “letting them down”.

I’ve already suggested what you should check and what you should do, I don’t think any logs are needed.

All the share prompt does is adds the folder locally with the same id, you can do that manually without the prompt to the same effect.