syncthing 0.14.7 via osx/homebrew not working

Hi Updated yesterday via homebrew. It is listed as running, I also restarted it,

brew services restart syncthing


  • web gui can’t be reached
  • is not syncing. Phone says my Mac is ‘disconnected’

Any ideas? Thanks

EDIT: Version is ‘stable 0.14.9’ . The local folder is named 0.14.7

We don’t support brew. Best you seek help with the people who package syncthing for brew.

Unleas you can provide logs and logs are indicating some sort of problem.

Brew is not the best way to go. I have created a native Mac OS X application package which bundles a tray helper and syncthing. Just have a look:

1 Like

If you still prefer to use brew (like me), and are still having trouble, please try the following:

  1. brew services stop syncthing
  2. pgrep syncthing
  3. brew services start syncthing

If step 2 gives any output, you have something weird going on – maybe syncthing is installed through some other package manager?

Otherwise, please post the log from /usr/local/var/log/syncthing.log and can try to think of more.

1 Like

@MikeLund Okay here is the log, pgrep returned ‘5596’. (Removed my ID).

[OQEBH] 11:15:48 INFO: syncthing v0.14.9 "Dysprosium     Dragonfly" (go1.7.1 darwin-amd64) brew@elcapitanvm.local 2016-10-17 07:21:58 UTC
[OQEBH] 11:15:48 INFO: My ID: xxxxxxxxxxxxxx
[OQEBH] 11:15:49 INFO: Single thread hash performance is 159 MB/s using crypto/sha256 (156 MB/s using minio/sha256-simd).
[OQEBH] 11:15:49 FATAL: Cannot open database: resource temporarily unavailable - Is another copy of Syncthing already running?

@jerryjacobs Great idea, I did replace homebrew install with your app. Unfortunately problem remains. Same log output as above.

Thanks to both of you.

Yep, as the message says (and the pgrep confirms), syncthing is still running, so it is likely that something else is running syncthing. You will want to find and uninstall it from any possible locations. pgrep -lf syncthing will hopefully show where that process is running from, will be /usr/local/opt/syncthing/bin/syncthing for example if it’s running via default brew.


Ok, couldn’t get to it right away. All is well thanks @MikeLund

hmmm, port was moved from 8384 to 59069 for laptop web gui. Not sure when or why that happened. Any rate it works.

It moves to a random port if the one we use is taken at the point the config is generated.

1 Like

I had multiple versions of syncthing installed with Brew somehow. I removed them with brew uninstall --force syncthing. Maybe that will solve the issue for me.

I am getting the same issue as @vv111y and using Brew.

1 Like

Hi Jerry - I too have tried and failed to install syncthing using brew but not being familiar with Terminal relied on copy and paste of other’s work - last time I got a permission denied when homebrew tried to install itself and no idea what to do, so the idea of a “packaged method” is great. I clicked your link but I’m afraid I’m clearly too dim or experienced to understand what I download/run from the site. Is there any chance you could point me to an idiots guide? Running El Capitan on a Mid 2012 iMac 27". Really want to get away from Resiliosync!


Like most of the Github project (including Syncthing), the releases are in the Releases tab. There you can download the .dmg file and install it.

1 Like

Thanks for that - I was originally trying to install the program so that it auto runs since it will also be on a remote machine as well (and when it falls over the only way to recover is to remotely cycle the power connector so it has to load on reboot really) - do you know if thats an option in the current build?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.