Syncs, but "Running (Offline)" and missing API key

Fresh 1.2.2 installation on a brand new OSX machine (Mojave). Connected to three other OSX machines (ostensibly) on the same local network.

Syncthing in the menu bar, however, will only ever show as “Offline (Running)” (with an amber dot). How do I get this to “Online” (green)? Any help appreciated.

And don’t know if this is related, but under Preferences the is API Key field is empty (and “Test” with a red dot). There is an API Key shown in General Settings in the GUI, and I’ve tried regenerating and copying into the field in Preferences, but nothing has gotten the API Key to stick there.

1 Like

@rsmyers I’m encountering the same thing as you - but interestingly, only one ONE of two MacOS (Mojave) machines where I’ve done fresh installs of 1.2.2. Strangely, one of them DOES show online - which you would think would provide me everything I need to diagnose / troubleshoot / analyze the differences. Alas - I can’t figure it out. It doesn’t seem to be the firewall config on the local workstation - and while I haven’t enabled upnp on my network firewall – I have full access to and familiarity with it, and the difference between the two client systems isn’t jumping out on me.

I read other threads talking about the Discovery service, and DNS – but both these machines are on the same LAN, with the same client configuration (at least, to some level of detail: Every machine is a snowflake, right?).

I’ll keep an eye on this thread - and report back with anything I discover in my pursuit of resolving this mystery.

Peace, Billy

Hi, same here. Problems seems to be the setting “Use HTTPS for GUI” in the Actions - Settings - GUI menu.

Whenever that is enabled the API doesn’t work. If you disable it then the API works and the “Running” service changes back to all green (both API and Service)

I do not want to use Syncthing without HTTPS so i guess i just wait for e fix for this problem.

If it doesn’t work at once, try re-generate a new API and copy it to the field in the Preferences and restart your Syncthing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.