Syncing very large folders on Android

Let’s say, I have a very large folder on my computer that I would like to access remotely on an Android device using Syncthing. Is it possible for me to list the folder only and fetch or upload files on demand without syncing the entire folder?


It has been requested before:

you can also go to the github discussion:

I was wondering about this too. I have huge home file storage server which i’m syncing with working computer and it’s working really nice. (Thanks for this excelent piece of software!) Problem is that i can not sync those files to my laptop (let alone android device), as there is not enough space on them for all files and i would really really really like to. It would be really useful if there would be option that one could turn on which would make those kind of machines (laptops, mobile devices or even computers with small HDD) that would make them sync only data about existance of files / folders which would be than used to turn on selective download of needed files / folders. I’m guessing that in syncthing administration gui there could be a file / folder tree where you would have checkboxes that you could turn on which would make syncthing download whole file not just info about that file.


Ok. Ignore does solve problem but it does take some typing of ignore rules once you want to get file to your machine. Having file tree with buttons / checkboxes would be more user friendly but this will do for now. What i notices is that i can not “unignore” file with certain name (win machine). This is what i have under ignore rules:

1.txt 3 - Copy (14).txt *

1.txt get’s synced, but 3 - Copy (14).txt does not. I have no idea how to make that file sync this way. I’m guessing it has something to do with () but i don’t know how to escape em.

You have to escape the ( ) as we do regular expression type of matching, which means that these have a special value. You might need a single or a double \ when escaping.

I tried: a) !3 - Copy (14).txt b) !3 - Copy (14).txt c) !3 - Copy \(14\).txt

None of it will sync. What am i doing wrong?

Have you tried double \ ?

Sorry for late replay, but i was forced to drop whole thing for some time. Anyway, currently i have this in ignore file: !1.txt !3 - Copy \(14\).txt * 1.txt is being synced. 3 - Copy (14).txt is not being synced

I tried with one \ and double like it’s now. It’s win7 64bit machine. Weird file name is from copy/paste process of one single file. Windows add “copy and number” to every each new copy.

So I believe this was fixed in the latest release (commit 1e4b2133f6a3b1fc46dca4f2df5013c04db8f2d5), and you shouldn’t need the \ anymore.

Yes it is. It’s working without escaping now. Thanks for your trouble!