Syncing empty folders because of the sub .stversions folder

Hello there,

I use the beautiful Syncthing to sync repositories of my Dev work. It works fine for me, and it handle versions as well. Syncthing rocks ! But, Something seems to be wrong about the mechanics of syncing.

Lets explain this into a quite essential example :

Repository to be synced is FOO, between 2 computers. firstly, the following contents is shared : FOO
FOO\Folder1\File1 FOO\Folder1.stversions\File1timeStamp //only owned by the “passive” computer

Assuming that I’ve edited the File1 later by 3rd soft on the “active” computer, whatever. And assuming that I use the File Versioning feature for this repository on the “passive” computer

This works fine.

If I now move File1 into the Folder2, then delete the Folder1 (again with the “active” computer), It makes the right thing to happens. FOO
FOO\Folder2\File1 FOO\Folder1.stversions\File1timeStamp //only owned by the “passive” computer

The “passive” one keeps the FOO\Folder1.stversions\File1timeStamp at this place which is fine while moving files is not handled by Syncthing yet. (

The problem is that it makes the “passive” computer to resync toward my “active” the FOO\Folder1\ , empty.

I guess syncing empty folder is a need, but maybe add an exception about those empty folders that only contains the sub folder .stversions .

Thank you, I tried hard to keep the topic short.

Yep! This is issue (“deleted folders come back”), solved in the v0.9 betas.

(I moved the .stversions directory to the root of the repo instead of having a bunch of them.)