Syncing being done via Relay and not LAN

Hey, I’m using v1.2.2 on both my android phone and windows. They sync via Relays and not LAN, despite being in the same subnet. How can I avoid this?

Phone: 192.168.1.200
Windows: 192.168.1.201

On syncthing-android’s side, I’ve changed desktop syncthing’s address from dynamic to 192.168.1.201.

I realize this post is similar to the following, but I know that I don’t have AP isolation on. Also, waiting some minutes did not seem to help for it to sync via LAN.

After going into the advanced settings, disabling relays and the announcement server, syncing works just fine (with 80 Mbit/s) via LAN, instead of 10 Mbit/s via Relay. I did this some days ago. Today it synced via relays again, I can’t really tell why. I disabled relays again and it worked.

Also: As it completely uses up my upload bandwidth, I can barely browse the web.

You could enable connection logging to see what happens, perhaps local device discovery takes too long, even though we do wait for it before we try our first connection attempt.

1 Like

Tried to debug this, now it connected via LAN. Possibly it cached the IP address? How can I further debug this?

You haven’t explained what you’ve tried.

I’ve explained which logs to gather, which provide information about addresses used and discovered already, that log should be all that is needed.

1 Like

I had enabled connection debug logging. It synced via LAN instantly. I will try it again in some days and post the logs.

Works fine now. Not sure why it broke the 2-3 times before I changed the settings.