Syncing a VeraCrypt Encrypted Container File

Hi there; I have v0.12.11, Windows (32 bit).

I try to sync a folder that contains a VeraCrypt (ex-TrueCrypt) container volume, which is essentially an encrypted large file (512 Mb in my case) which can be mounted as a drive.

First time, the sync worked so both peers have the same file. Now the file has changed on one peer, but both still report it as “Up to Date” and the files are different.

Shouldn’t Syncthing have noticed that the file has changed?

TrueCrypt (and I assume also VeraCrypt) won’t by default update the “Last Modified” time on the crypt when it’s updated, so Syncthing never notices it changed. Somewhere (in the VeraCrypt settings) there’s a setting to change that - I can’t remember where it is off the top of my head, but if you search the forums an old thread has screenshots.

Here, at the bottom:

That’s absolutely right, it worked!

I’m not sure if VeraCrypt will like containers modified this way, but as long as it isn’t mounted while being modified at block level it should work, I suppose.

thanks a lot!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.