Synchthing prevents disk spindown

I run a NAS server using Synchthing to share a folder across multiple devices. The hard disks in the NAS are set up to spindown after 30min to conserve energy. When Synchthing is running however, the disks are spin up regularly even if none of the synchronized devices is changing any files. The disks are spun up even if all the connected devices are powered off. What could be cause of this behavior?

From time to time Syncthing checks the individual folders for changes. Then the indexing is updated. These processes take place at regular intervals.

The spinup is isn’t caused only by the rescanninng process. I have set the rescan interval to 24h, but the disks are activated almost every hour. Is there another option that I could edit?

Move the database off the spinning drives into ssds. We periodically record stats about folders and devices in the database, so there will always be some form of disk activity.

The configuration directory with the database files $HOME/.config/synchthing is already located on a SSD.

Then at least to me the reason why your hdds keep spinning is not clear. You can use something like to log all disk access to find out which program accesses what file.

The disk spins up every hour approximately due to version control. The fatrace indicates that Syncthing edits the .stversions folder hourly.

I use staggered file versioning with the default path for the file versions and a maximum retention of 365 days. I will check if the problem can be resolved using another file versioning method.

It would be useful though in this case if an option was available in staggered file versioning to control how often the contents of .stversions are edited (e.g. for deleted old versions) in order to avoid excessive activations of spinning disks.


We might change the hook for this so it runs together with scans, following that frequency. That would make sense to me.


Creating an issue on GitHub will increase the change that it wont get forgotten.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.