Sync Stuck: "scanning in progress" that never ends

Hi all, I’m facing a problem with Syncthing and I’m looking for your help to fix it.

The problem I’m having is that when I use Syncthing to sync data between my remote devices, the sync process seems to hang. Even if I leave it running for some time, it never completes and this causes my files not to transfer

I’ve tried basic troubleshooting steps like checking logs, verifying file and folder permissions, and making sure there’s enough disk space, but the problem persists. I also recreated the connection between the devices from scratch, but that didn’t work.

Below are some details about my synchronization environment:

Server Operating System: Windows Server 2012 R2 Standard Client Operating System: Windows Server 2022 Syncthing Version: v1.23.6 (letest)

I would be extremely grateful if anyone in the community could offer their troubleshooting experience and possibly shed some light on why the sync is not completing successfully.

Thank you all in advance for your attention and support. I’m available to provide more details or follow specific instructions to help resolve this issue.

Can you post screenshots of the Syncthing Web GUI from both devices? Please make sure to include the folder in question with its global and local state visible, etc. Also, what kind of files specifically are you trying to sync? Can you provide some details about the hardware involved?

server configuration Screenshot 2023-08-04 at 10.59.45

Screenshot 2023-08-04 at 11.12.02

client configuration

In source directory there are .PDF and .CSV files. What specific hardware details do you need?

Basically whether the hardware is decent enough to handle Syncthing efficiently. The first scanning process is actually about hashing the files, which can be slow depending on your hardware, filesystem, antivirus running in the background, etc.

How much time exactly has passed since the scanning process began? Also, are the files in the folder static or do they change constantly?

the requested information is below. Virtual machine specifics:

  • memory: 30 GB
  • processors: 16 (4 sockets, 4 core)
  • disk: 400 GB SSD
  • Antivirus: Not installed

the loading of files (.pdf and .csv) into source directory is automatic and differential

@tomasz86 could you help me?

How long have tried to wait the longest for the scanning process to finish? Or does it scan like constantly with no breaks in between whatsoever?

You could try to go to “Actions → Logs → Debugging Facilities”, enable “scanner”, then go back to “Logs” and see whether there’s actually anything going on there while the scanning is running.

@tomasz86 Can you give me some pointers on what to look for?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.