Sync is frozen, tried several things

I recently configured a Raspberry Pi with Syncthing. Worked great with my Desktop (both hard wired) but has issues with any other device. I have an Android phone (Pixel 2) and a VM (linux - openSUSE Leap 15) at the office.

Right now my VM is stuck at 8% (where it’s been for several hours) and the phone is at 0%. I opened port 22000.

What else should I check for? What causes this?

No idea, please provide screenshots of the web UI and/or logs (mostly screenshots).

Attached. As you can see it went a whole 1% percent since I posted this. Where can I find the log in Linux?

Here’s the other one since I can’t attach more than one image:

I solved this. I am still not sure what the issue was, but because I introduced a new device (RP) which is meant to be the central hub, I treated it as such. Here’s what I did, and this is how I will setup Syncthing from now on:

  1. I deleted ALL devices and ALL shared folders from ALL devices. This means, clean Syncthing, no device knows on other devices, no folders.
  2. I joined devices to the main “hub” one by one: the RP got invites from one device at a time. After the device was added, I added the folders from that device to the main hub.
  3. from the main hub (my RP), I shared back folders to other devices they should sync with. So, if my phone has a “personal” doc folder which is also on my home desktop this is what would happen: I would first pick a device (say the phone) to share the personal folder with the hub. I would then share back from the hub to the home desktop.
  4. repeat until all devices (5 total) are connected through the hub.

So, no one device knows about the others. They all just sync to the hub. The hub knows about all the other devices. I log into the hub to share folders back. This elimiates duplicated folders.

Now I just have a crap top of conflicted files from previous setup… but I’ll sort through them. And I hope I won’t touch this for a while.

You are running v0.14.18 - that’s ancient. While it might work just fine for you, it’s not something I will try to debug a problem on. There’s up-to-date apt-packages on

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.