Sync failed


First this is my configuration

  • Distant : UltraSeedbox with Syncthing
  • Locally : OpenMediaVault with Syncthing (docker)

I managed to connect the 2 machines together. I shared my first folder but I have an error on locally Syncthing:

2020-07-02 00:15:34: Failed to create folder root directory mkdir /srv/dev-disk-by-label-Files: permission denied

2020-07-02 00:15:34: Error on folder “radarr” (nvjxh-tcrae): folder path missing

That’s weird because the folder already exists. For the second warning I don’t know, I put the good path on the seedbox syncthing.

Tell me if you need more information, thank you !!

Syncthing doesn’t have permissions for that directory, just as the error message says.

That’s weird, on OpenMediaVault I sett permissions to:

  • Changing owner to root:users …
  • Change directory permissions to 2777 …
  • Change file permissions to 666 …
  • Done…

Is syncthing running as root?

Things like Synology and other weird NAS things sometimes use weird permissions, so chmodding is not enough because they use ACLs.

Suggest you search previous forum threads for advice, or perhaps ask on the seedbox forum.

I just checked permissions, I don’t know if it’s good, I’m a beginner Linux user :frowning:

So thank you, I’ll try to ask the seedbox forum if I can’t resolve the issue

Update : I tried to set /syncthing as path (volume point to /srv/dev-disk-by-label-Files/Syncthing on Docker/Portainer). This is not the same error :

2020-07-02 00:57:15: Failed to create folder marker: mkdir /syncthing/.stfolder: no such file or directory

2020-07-02 00:57:15: Error on folder “Radarr” (vkgsd-h2ftm): folder marker missing (this indicates potential data loss, search docs/forum to get information about how to proceed)

It works, I applied recursively permissions on the folder and it’s good :slight_smile: I don’t know why isn’t worked before

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.