Sync conflict on new file creation


Sync conflict created immediately after creating a new file. This happens fairly frequently. The file name suggests that the machine that created the conflict is my workstation, which is the same machine where the file was created/edited. I did not leave this machine, so the file was definitely not edited on any of the other machines.

How do I determine why this is happening?


I have Syncthing running between 4 Windows machines (using SyncTrazor) and 2 Android devices. One of the Windows machines is intentionally left running 100% of the time to serve as a SyncThing server.

Are you running the newest version of Syncthing everywhere? Are all the settings at default or have you tweaked anything (e.g. enabled syncing extended attributes or ownership)? Have you tried enabling “ignore permissions” in the Advanced folder tab?

  • Workstation v1.24. FS monitoring disabled. Scans every 2m.
  • Laptop v1.24. FS monitoring disabled. Scans every 2m.
  • Server v1.24. FS monitoring disabled. Scans every 1m
  • Old machine v1.24. FS monitoring disabled. Scans every 2m.
  • Phone v1.23.7
  • Tablet v1.23.6 (updated today to 1.23.7)

I previously tried disabling FS monitoring on the Windows machines hoping that a slower sync cycle might prevent these issues. However, I couldn’t find a setting in Android to set a custom scan cycle, so those devices watch for file updates.


  1. I’ve just enabled ignore permissions on the Windows machines. I don’t see this setting in the Android client.
  2. Is there any way to quickly propagate settings changes across all devices for a folder?

You need to use the Web GUI on Android. You can access it from the left slide-out menu in the Syncthing app.

Specifically this setting is already enabled by default on Android. For anything else, the standard GUI is available from the menu.

This is what I was going to guess at, because it was already enabled on my Android devices. :wink:

So that means I have ignore permissions enabled across all my devices and now we wait. Thanks for the help so far. :pray:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.