Symlinks forces re-syncing again and again

#1

Hello, I synced my Linux home folder with a Raspbian. All files are synced well, even the symlinks. But the symlinks will be re-synced again and again. I read a lot of topics here in the forum. but I couldn’t find my issue. All the other topics about symlinks seems to be handle the following of symlinks, what I do not need.

Syncthing version of my laptop is 1.0.1. Syncthing version of the Raspbian is v0.14.18-dfsg1.

Can anybody help me?

0 Likes

(Audrius Butkevicius) #2

Any clues in the logs?

0 Likes

#3

I found that the default setting for symlinks of raspberry syncthing version 0.14.18-dsfg1 is: <symlinksEnabled>true</symlinksEnabled>. I changed it into <symlinksEnabled>false</symlinksEnabled>. But now I have multiple unsynchronized objects, e.g. Hausarbeit.ott symlink not supported.

I do not need to follow symlinks but it should at least synchronize the link itself. What can I do?

Thanks for your help.

0 Likes

#4

That setting hasn’t existed (or at least had no effect) for a long time. But your syncthing version on the raspi is over 2 years old. Your problems will porbaply be resolved by a current version.

1 Like

(Max) #5

Your outdated raspberry version looks like the one in the offical debian repos. If you want a up-to-date version, have a look at the syncthing repository at https://apt.syncthing.net/.

0 Likes

#6

Hello, thanks to all. After I installed the current version 1.0.1 the issues have gone. BTW: I saw that the version I use on my Android phone is 0.14.51. it seems to be old as well. Is there any update available?

0 Likes

(Martin) #7

This is currently discussed in “Is the default Android app actively maintained at the moment?”.

From my personal experience: the Android version has no problem to synchronize with the 1.0.1 version.

0 Likes

(system) closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes