Sycnthing doesn't want to sync. Stuck at 1%

I tried to sync files from my linux pc to android phone. It doesn’t want to sync. It worked yesterday but today I got the folder marker issue thing so I fixed by following the solution in the forum and make .stfolder folder. Now it says no issue but it does not want to sync. Screenshot from 2022-10-21 10-55-33

It says up to date. Screenshot from 2022-10-21 11-01-08

But It’s not up to date at all. The file is not synced. The app is running in both devices. What went wrong here?

Reading FAQ, I’m assuming it’s the slow download. It says: “Second, if one of the devices is a very low powered machine (a Raspberry Pi, or a phone, or a NAS, or similar) you are likely constrained by the CPU on that device. See the next question for reasons Syncthing likes a faster CPU.”

But it does not propose any solutions. I don’t know what to do. My address is normal, and I’m on LAN.

I do have ufw installed. But it’s still had same problem even after I ran sudo ufw allow syncthing and sudo ufw allow syncthing-gui.

1 Like

Look at the folder status on YAL-L21, that’s where you’ll see what is the problem.

1 Like

Where can I access this “folder status”? I can’t seem to find such menus in the app.

Is it this one?

Or do you mean this one? The green text that says “Idle”.

I still can’t tell what’s wrong.

Folder is not paused, I also checked “Watch for changes”, it’s still not doing anything.

1 Like

Hmm I can’t edit my post anymore for some reason.

I will just add that, I tried to copy another files and it worked fine. So only a single file does not want to sync.

Ah good thing I catch this issue now before I tried to syncthing a folder with a lot of files. Not noticing a single file is lost would be an issue. The file is named LAN Video Controller.apk

My ignore pattern, .stignore is empty. Also if I copied that LAN Video Controller.apk file, the duplicated file will be synced, but not the original.

What do you think is the cause of this unreliability? I would like to know in case it happened again in the future. Hopefully it can be prevented.

1 Like

This is irrelevant. The slow CPU constraints are usually only talked about when dealing with large amounts of data, and not a single, small-sized file.

Your folder on Android is set to “Receive Only” and it has been changed locally, hence the “Locally Changed Items” and the “Revert Local Changes” button. Have you modified anything on the Android side? If you want to get rid of the errors, you should use the “Revert Local Changes” button first, and then Syncthing should continue to sync the file that is currently stuck.


the only modification I did is manually creating .stfolder following the instruction to fix error. And deleting “copies” of previous version of my file in android which does not exist in my pc.

Why does it even create copy when I set file versioning to none? (It had always set to none since the begining since it’s the default)

This issue happened before I set syncthing folder setting to “Receive Only” as far as I remember but I could be wrong.

I just set both devices to send and receive, and the files on my pc got deleted. I wonder if there is a setting that just mirror things from one device to another. Like rclone.

Hmm but maybe this is better as long as it doesn’t keep multiple version of the files.

1 Like

I don’t think this is relevant to the problem at hand, but where did you get the instruction to re-create .stfolder manually though? This can be a very dangerous operation, in the worst case resulting in wiping out the whole folder on other devices, so please proceed with caution and do it only if you’re 100% sure about what you’re doing.

Conflicted copies and versioning are completely unrelated (please read up for details). If you haven’t edited the file on Android, yet you still got conflicted copies, then I’d assume you may have been hit by The issue has already been fixed, but right now the fix is only available in the current release candidate, and not the stable version.

1 Like

Syncthing just stopped working. I don’t remember the exact error message but it told me to “google it” to fix the problem instead of directly showing me the link to the solution. Which I did, and the solution I found was to manually create .stfolder. The solution is in the forum, it’s top result.

Yes I haven’t intentionally edited the original files in my android phone. Actually, my original file in android is magically disappeared along with the issue that I mentioned above. But it does not dissappear on my PC. At the time, the settings for both folder is still default “Send and Receive”.

1 Like

Yeah, what you found isn’t what should be recommended as a general-type solution. The error message being less-than-ideal is a known issue (see I don’t remember it asking to google the answer, but the reason why Syncthing asks to come to the forum is because .stfolder missing can indicate a wide variety of problems, and it’s important to know what’s happened exactly before proposing any specific solution.

In this specific case, do you use any “system cleaners” that remove empty folders? This seems to be one of the more common reasons on Android specifically, especially since some custom versions of the OS even have such a cleaner built into them.

1 Like

Ehm no I’m not aware of such thing. I never set any auto clean since I rarely save anything there anyway.

I forgot to mention there are two original files, another one is called LAN Video Controller.apk.idsig but that one did not magically disappear.

I’m 100% sure it asked me to “look it up”, not necessarily use google (I used the word google like a verb). But I don’t know how I’m supposed to ‘look it up’ other than searching for a solution using the most modern, popular, cutting-edge search engine, Bing.

1 Like

Can you post new screenshots of the Web GUI on both sides to show the current situation? If possible, please show the whole Web GUI (and not just cut-out parts of it).

1 Like

Here is the current screenshot. Now it’s actually up to date after I changed both devices back to Send and Receive. I re exported my .apk files.

Thank you for your assistance.

oops forgot about this one.

1 Like

Hello, sorry for posting again after the thread ended.

Looks like my phone does have it. It’s on by default and it includes auto-deleting .apk files. I thought I didn’t have it because I never turned them on manually like in my previous phone. I don’t even know if such feature exist in my current phone.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.