Suddenly my Windows PC cannot see my Android device

Hello all

Here is an issue that I opened on the main Syncthing github. Upon so doing so I was told that it would be best to report the problem here, i.e. in the forum. So, here I go.

Does your log mention database corruption?


Include required information

Windows PC : Windows 10; Syncthing v1.23.5; Windows (64-bit Intel/AMD); Firefox ESR 114.0 Android phone: Android 13;v.23.4 (newer version has not appeared via the Play Store), Android (64-bit ARM)

As of today - or at least it was today that I noticed the problem - my Windows PC cannot see my Android phone, and vice-versa. I have a Linux laptop that (Syncthing-wise) sees both the Windows PC and the phone. Things I tried to no avail:

  1. disabling my Windows PC’s firewall and VPN;
  2. deleting the Windows device on the Android device, and recreating the former;
  3. delete the Android device on the Windows PC, and recreating the former.

Except, ah: now - some ten minutes after 1 and 2 - the Windows PC and the phone do see each other. But, now, there seem to be some items that are stuck out-of-sync between the devices. I tried the ‘override’ option but files newly on the phone did not reach the PC. And - even more recently - I find that the Windows PC says, of the phone, this: ‘no recent network activity’; and, now, on the phone, the Windows device shows as disconnected.

I attach the Windows log [well, I’ve put it here], as it was [i.e. in the state that the log was in] when I first had problems. On Android, I managed to see the log but I don’t know how to save it.

And the very most recent development is . . syncing has now resumed between the two problematic devices. Weird.

So, your only problem now is there are some out of sync files that haven’t been synced to Windows.

  1. are newer files properly syncing to windows?

  2. is the Android folder so big you can’t just start over? Remove the folder from syncthing on windows and tell the Android not to sync to windows then rename the folder on windows and establish syncing between Android and windows to a new clean windows folder and let it populate with all 100% of the Android files.

There might be other ways but this one works for me.

Dear . . er . .

Thanks for the reply. Sorry for the lateness of this response. (I got no notification of your reply. I’ll have to look into why.)

The problem of the phone and Windows not seeing each other has reoccurred. I tried to implement your suggest nonetheless but since the phone can’t see Windows, the phone isn’t asking Windows to reach a directory to contain the Android files.

That Windows is running VPN seems implicated - though until recently the VPN gave me no trouble. For, when I disable the VPN, the phone and Windows see each other; and now I’m getting the expected request on Windows to add the Android directory. Indeed the VPN (which uses Wireguard) seems the fundamental problem: when and only the VPN is on, devices stop seeing each other.

Does your VPN software have the option to configure exceptions for apps that will bypass the VPN? My VPN software calls it split tunneling. Perhaps you can set the VPN software to not VPN control the syncthing software? My VPN software also has another feature called local discovery that can be either enabled or disabled. You should check and see if your v p n software has a local discovery option that you can enable.

I have VPN software running on both windows and android and they can see each other fine because the software has a feature called local discovery that is enabled.

Turn this post to “Tracking” and you will receive notifications when someone posts a message.

Thanks for the help.

Notifications: the site had the wrong email address for me. I gave it a working email, confirmed that email, and still I did not get an email notification. Hmm.

Split-tunneling: yes, my VPN has that, but whenever I try it, for some reason it blocks all Internet connectively for the supposedly let-through apps. And I tried it just now with Syncthing, and Syncthing seemed to keep working (!), but the original problem persists. The VPN is set to exclude my local network, though (and I think that that is what you mean by ‘local discovery’). Perhaps I should add: my PCs (Windows desktop and Linux laptops all use a VPN), but the Android phone doesn’t.

OK - everything’s working again. I think the problem was that I had made a change to firewall rules on the Windows PC. I don’t understand firewall rules, and (nevertheless!) have a complex firewall setup in that I use Windows Firewall but with a third-party front-end for it. I reverted a change I’d made to the front-end. The difficulty here is that, at least or especially if one does not remember all the changes one makes, there are so many factors: router; Windows firewall; vpn; Android; the dual-band connection that I have on Android (which doesn’t work properly with my router’s static IP functionality); and perhaps more!

I tried, and failed, to find a way to edit my previous post. So I’ll have to add the following as a new post.

I wonder also whether the problem documented here, and fixed already in a release-candidate, might be (partly?) to blame. Time will tell.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.