.stversions folder is missing when File versioning is enabled

.stversions folder is missing when File versioning is enabled

I have a couple of added folders to Syncthing. Everything is working fine, but .stversions folder appeared only in one of the shared folders.

I have tried to enable/disable different File versioning options and restart Syncthing. But File versioning still does not work.

It’s created when it’s needed, that is when the first version is created.

I’ve tried to remove files and folders. Files just now removed forever. Still no any .stversions folder in my shared folder. File versioning is enabled.

Assuming versioning is turned on on deviceB: If you delete a file on deviceA, then you will get an .stversions folder on deviceB. You will not get an .stversions folder on deviceA (regardless of A’s settings) as the OS deletes the file before Syncthing can do anything to remember it or copy it into the .stversions folder. This is expected behaviour.

1 Like

Thank you for your reply. I think that I got it. I think it will be good to add some notes about this to the documentation.

I added an extra callout to docs/users/versioning to be very specific about this.


As far as I remember, the doc clearly states .stversions isn’t synch’d

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.