Strange web interface issue

I have a strange issue on one of my machines: the web interface doesn’t work in Google Chrome. It loads, but shows nothing under “Folders” and “Devices” and zeroes under “This Device”, and the browser console is full of http://localhost:8384/rest/events?limit=1 403 Forbidden's.

In Firefox it works. When I port-forward Synching interface from my server to this machine, that interface works in Chrome, too.

I have Chrome with presumably the same settings (and synchronized) on another machine, and on that machine there are no issues.

There obviously is a place I failed to look in for the solution, but where can that be?

I’m sure you tried clearing browser cache. Maybe check in developer tools - “network” tab what is loaded before?

Yep, no amount of cache clearing helps.

It looks like things get loaded ok (this is after cache clearing):

And then - boom.

other suggestions: checkbox “disable cache” (top of developer tools) and reload again - or try switching to another language, maybe there is some unknown character in ru?

Nah, makes no difference either way.

last idea: install new Syncthing somewhere and try it in Chrome

Oh, I just found out it works in Porn-Mode on the affected machine. So there must be some misconfiguration in my Chrome for sure (which was obvious from the start, but even more so now).

Plugins that don’t run in incognito mode? Maybe a privacy thing that thinks the events endpoint is a usage tracker?

Tried switching off every plugin, naturally. No result.

Even funnier: another machine, also running Syncthing, all Chrome settings synced with problematic one - no issue.

And the thing that drives me completely crazy: if I port-forward 8384 from another Syncthing-running machine, I can connect to that web-interface from this problematic Chrome.

OK, I got it working, sorry to have bothered everyone. I’m sure the chances of anyone else getting this (completely Syncthing-unrelated) issue are practically zero, so it’s likely not even useful to have this documented here on the forum, but just for the sake of it:

In case you ever make use of the option to return custom HTTP headers from a Hugo development environment server, be aware that not only does Chrome apply restrictions from those headers to all the localhost, it also doesn’t seem to care when restrictions get removed. So if you ever impose any restrictions via those headers, to restore the normal Chrome–Localhost interaction, in addition to removing those restriction you also need to restart both Hugo and Chrome at the same time (i.e. there must be a moment in time when neither Hugo nor Chrome are running on the machine). Otherwise, Chrome somehow keeps thinking localhost restricts things (when in fact it doesn’t) and seeing 403s where none were returned.

Isn’t software awesome?


Nice :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.