Stopped in middle of sync, knows not done, refuses to continue.

I’ve been using Syncthing for many years now, mostly without issues.

My main server Central (NixOS, ZFS) has ~760 GB. I had a Windows 10 machine Tachyon (Synctrazor, NTFS) that never had sync issues. A few days ago my SSD died and I set it up again with Windows 11 (Synctrazor, NTFS) and the same name.

After “connecting” my devices in both Syncthing instances and setting up the folders to sync back everything worked fine and I let it run over night.

The next day though, I could see Central under Remote Devices says it is trying to sync to Tachyon (Syncing (60%, 305 GB)). However, both Download and Upload Rate are now 0 B/s.

Interestingly enough, it seems to have “randomly” stopped right in the middle of syncing things. For example, I have a folder called Company which says “Up to Date” on both devices. Yet, clearly my Windows 11 machine is missing some documents I find on my server. These missing files are not ignored, they seem to be just randomly missing from various folders.

However, no matter what I do, Syncthing just refuses to continue syncing them.

Things I’ve tried:

  • Restarted both devices and services multiple times
  • Checked device IDs and Folder IDs match
  • Checked both “Advanced Settings” for any glaring errors (but I’m not super familiar with all the settings in detail)
  • Connected with and without VPN, and / or local LAN
  • Checked .stignore files
  • Paused / Unpaused / Rescan various folders
  • Paused / Unpaused both devices
  • Enabled some logs and glossed over them (but frankly don’t know where to start with the logs)

Long story short, I’m out of ideas at this point. It would be really nice if someone could give me a hint what else to try.



Are the problematic files contained in a single folder or spread among different ones? Without knowing exactly what the culprit is, I don’t think there’s any magical fix that will “unblock” the files and force them to continue syncing.

If all or most of the files belong to a single folder, you could try removing and re-adding that folder, which will force Syncthing to re-index the files and hopefully sync the missing ones. The atomic option will be to reset the whole database, but I’d try to avoid it, especially with that amount of data.

Just to be sure, are there any panic logs present in your config folder (for the exact location, see

1 Like

I haven’t seen any pattern for files that don’t want to sync.

The failing files are often even shorter than sibling which sync, and have similar names (e.g., rc3.pdf doesn’t sync, while final.pdf syncs in the same folder).

I also haven’t seen a folder pattern. While some folders don’t show up entirely, most folders do, some just missing files.

About logs, I just checked the folder you mentioned. There are a few syncthing logs, which doesn’t contain the keyword panic, but a few errors, but most of them seem relatively benign, such as:

[XXX] 2022/06/26 19:04:26 INFO: Connection to XXX at [::]:22000- closed: reading length: Application error 0x0: closing
[XXX] 2022/06/28 20:55:46.391886 service.go:1110: DEBUG: dialing XXX quic://[XXX]:22000 error: dial: timeout: no recent network activity
[XXX] 2022/06/28 20:58:21.501958 service.go:1110: DEBUG: dialing XXX tcp://[XXX]:22000 error: dial tcp [2a03:1b20:4:f011::999e]:22000: i/o timeout

I didn’t find any other dedicated panic log.

The atomic option will be to reset the whole database, but I’d try to avoid it, especially with that amount of data.

For anyone else having this problem, I eventually tried the “atomic option” and deleted index-v0.14.0.db from C:\Users\[USER]\AppData\Local\Syncthing, and now it’s working again. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.