.stignore has no effect of scanning?


(Kaihs) #1

I’m sharing a folder that contains a subfolder .config/pulse for which the syncthing server has no access permissions.

This is the cause for the message shared_folder error while traversing /xxx/.config/pulse: permission denied

The folder status shows Rescans 1h Failed to setup, retrying

To avoid this I added /.config/* to .stignore, but that doesn’t seem to have any effect.

Does ignoring only refer to syncing and not to scanning?

Is there any other way to circumvent this problem? Changing the permission is not an option, as the pulseaudio daemon will change it back.


(Simon) #2

This is due to the watching for changes feature. If you do have any include patterns (!...) it will not take into account ignore patterns when setting up watches (events will still be ignored). You have two workarounds: Remove include patterns or disable watching for changes.


(Kaihs) #3

Thanks for the advice. Yes, I have include patterns though they refer to another subfolder. The complete .stignore looks like this:

/log/* !/log/.save !/log/.txt /backup/* /restoreDir/* /.config/*

I wasn’t aware that include patterns have an effect on watches, thanks for explaining that. I will try to move files around so that include patterns are no longer necessary.


(system) closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.