SSL Host not changed

I am using syncthing on a VPS. The name has changed and I also changed the hostname in syncthing. The ssl certificate is not renewed. How can I reset the ssl certificate?

The SSL-Cert is located in ~/.config/syncthing/. Delete the https-cert.pem and https-key.pem while syncthing is not running and it should create a new cert on next startup.

1 Like

Thanks but it also resets my hostname again :frowning: I can now see the old hostname in the title of syncthing and not the new one which I changed in the syncthing options. I again gives me the certificate error “wrong url”

edit: I did a restart and the name in synchting is now correct but the certificate name still points to the old name.

I cleaned up the hosts and set the new hostname correct in the hostname file. Everything is fine now! Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.