[Solved] Out Of Sync after pausing


First thanks a lot for developping Syncthing. It’s just amazing :smile:

Since 0.9, I have problem when I change some files very often. In the log, it says “Changes to “**” are being temporarily suppressed because it changes too frequently”. But it never starts to sync again, and any changes is then “Out of sync”.

Is it a normal behaviour? It’s not to me: I would expect to start syncing again after a minute or two.

Thanks for your help.


+1 … well, sort of I have also seen this temporarily suppressed message before. I don’t know what triggers it, and I can’t be sure it started with the upgrade to version 0.9.

I have a small TrueCrypt container that I keep inside a repository. I think I get this message when I decrypt the container and mount it while Syncthing is running. I am not 100% certain.

When I dismount the container, the messages go away at the next scan. I don’t have your problem where you remain out of sync.

So, the “changes too frequently” thing is actually removed in 0.9.4+ (because it uses more memory than the functionality it provides is worth).

But what it did was ignore large files that change often, for a while, to reduce the constant rehashing that otherwise happens. @NickPyz, you’ll run into this with your truecrypt container for example. When it’s mounted, and something is using those files, each time syncthing looks at it it will have a new timestamp and need to be rehashed. This can get expensive, fast.

It could possibly be efficienly reimplemented as a simple “don’t look at this file if it’s larger than X and was last scanned as recent as Y”, for some usefully dynamic values of X and Y.

1 Like

Good feedback. In future, I am going to start taking the node I am working from offline (Shutdown Syncthing) before I mount the TrueCrypt container. Thx.

I updated to 0.9.4 the 2 nodes, but I still got the problem. Files frequently updated are stuck in “Out of sync”.

Well, how stuck is stuck? Syncing a file that is changing underneath is tricky business.

Problem was solved with 0.9.10.