[solved] not finishing sync since upgrade to 0.14.4

hi all!

i’m having problems since the upgrade from 0.13.x to 0.14.4: folders are no longer finishing their sync to any node.


1 master, readonly, 2 folders, syncing to 2 nodes that are readwrite, and only syncing from the master node.

all 3 nodes are linux (debian based), all on 0.14.4

syncing stops at 43% for node 1 and 63% for node 2

additionally: node 1 was at 100% sync, but dropped to 43% when i added some more ignore patterns, so in theory node 1 only has to remove files… but even that seems to not be the case.

after removing the index file on the nodes, it rebuilds the index and gives the same problem. after removing the backed up folder and the index file, it syncs partially again but still stops before finishing.

none of the nodes gives an error in the log and all files used to be synchronized flawlessly.

i assumed a possible bug since no changes have been done to the configuration, the syncing worked in 0.13.x before the upgrade, and all nodes are connected to each other. so literally the only change is all nodes received an upgrade to 0.14.4 yesterday, but my ticket was closed and i was sent here, so… any help on where i have to look would be appreciated.

Typically either ignores or folders that are not shared everywhere. Screenshots?

My setup also suddenly has problems finishing syncing. It generally gets stuck at around 90%. I was able to solve it in one case by restarting syncthing on both machines a couple of times. It might have to do with the fact that the machines are not permanently connected.

even better now… overnight, it apparently finished syncing… but now it states my main node is out of sync with the others - which was not the case before upgrading to 0.14.4 (all nodes were in sync)

i am going to delete both remote repositories and let it sync up again, to see if it gets back in sync after that. i’m guessing it has to do with the delta indexing?

Jakob: there has been no change in the config or ignores, only the upgrade. afterwards i did add some ignores (like not backing up .scanned files)

  • i stopped all syncthing nodes
  • removed the remote repositories and index (which would hardly matter, because they actually contained the same content as the local node)
  • removed the local index
  • restarted all nodes

now they are syncing up, and what i notice is that the local node index was actually the problem after the upgrade.

I.E.: globabl state: 942 items ~88.0 MiB, local state 421 items, ~88.0 MiB, out of sync 420 items, ~88.0 MiB this while the folder was -without a doubt- in sync on all nodes before the upgrade (this particular folder almost never changes files, which is why i am sure.)

after the above, all nodes synced back up and i now have the 421 items, full 88MiB on all nodes. so for me, problem is solved… but i can’t help but believe it is a bug somewhere, since it happened after updating and it actually stated i had more files globally than locally (which was not true)

If you added files/folders to the ignore list after they were scanned, deleted them and then upgraded to 0.14.4, it could be related to this:

i doubt it is related, i upgraded before changing anything. it’s to say: they were in sync on 0.13 but i had an upgrade notice, so i upgraded all packages. after that, i did the same on the 2 other hosts (since it’s not backwards compatible) and THEN the trouble started.

i also did not lose any files (they were all present on all 3 hosts), it was just that syncthing didn’t seem to understand that fact. removing ONLY the remote hosts index didn’t solve it, but removing the index for ALL hosts did.

the solution i used (deleted all indexes from all the hosts) was enough i think (no need to actually remove the copied data, but i wanted to be thorough), but i wonder how it happened? a corrupted index somehow?

it actually sounds A LOT like this (solved, old) issue: https://github.com/syncthing/syncthing/issues/738

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.