[SOLVED] Filename not in UTF8 encoding; skipping.

Hello. I have just added a new machine to my network (an Orange Pi PC). I have installed syncthing and shared the same directory I’ve been sharing for months between the other nodes. But on this machine I keep getting errors like these:

2017-01-26 22:55:27: File name "Shared/Articoli/Africa/Northern Africa/Morocco/Chefchaouen/JPEG/escalier-bleu-by-jean-fran\xe7ois-gornet.jpg" is not in UTF8 encoding; skipping.

2017-01-26 22:55:28: File name "Shared/Articoli/Europe/Western Europe/France/Annecy/Vladimir Tkalcic\x87 - Annecy.jpg" is not in UTF8 encoding; skipping.

The same files are synced correctly on the other machines. Why is it not the case with the new one? :open_mouth:


Ok, I managed to find where the problem was.

The directory to be synced is hosted on a NAS which is mounted on the Orange Pi via Samba. In the fstab, the “iocharset=utf8” option was missing. Adding this solved the problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.