SOLVED 0.14.47 problem/bug with .stignore ?

I upgraded to the last version yesterday.

After reading the folder, apeared 15.000 files and 1,5GB to be synced… all the files ignored before, like thumbs.db (I have 25.000 folders, most of them with photos), some .ini files, office temp files ~* …

I checked the .stignore, in some servers the patterns doesn’t load, and I wrote again from other servers.











.stignore use has been changed ? I read in another post the use of a .stglobalignore should be used ? I shoud create this file in one of my servers and will be propagated to the other servers ? The changes to refer to the .stglobalignore shoud be changed in all servers manualy ?


1 Like

Maybe you’re seeing what I’ve seen on one machine:

0.14.47 changed the looks of Folder properties. There are tabs now, and it’s important to understand that the “Save” button seems to save what happened on all tabs, not just the surrent one (which looks like a bad idea to me, by the way).

One of the tabs is “Ignore patterns”. When you open Folder properties, it initially reads “Loading…”, then is replaced by what it actually found in .stignore.

On a slow machine, you might open Folder properties to tweak Rescan interval, for example, change what you see fit and hit the “Save” button before it has time to load .stignore properly. In this case the web interface seems to think that “Loading…” is in fact your new ignore patterns and OVERWRITES .stignore WITH “Loading…”!!!

I checked manualy, and I havent changed anything. One of my servers hadn’t the thumbs.db pattern. I checked on all servers with close instead of save.

The servers where apeared the 15.000 files to be added had the pattern. And the server up to date hadn’t it.

Then syncthing tried to add 15.000 files to other servers that they ignores.

Just added the ignore pattern in the fault server, and in 5 minuts all server are up to date.

Thanks and sorry

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.