[Solved] 0.11.20 stops all synced folders

The addition of this:

Stop folder when running out of disk space (#2057, @Zillode)

Now stops all my synced folders with this in the console:

[KKAP5] 12:28:24 INFO: Skipping folder folder_name scan due to folder error: out of disk space

Is there a work around the ignore this:


1% doesn’t work for me because I do have a rather large disk, which is full-ish but I monitor it myself and 1% is just too large of a figure. And since the setting is an int, I can’t set it to anything smaller:

[KKAP5] 12:33:03 FATAL: Configuration: strconv.ParseInt: parsing "0.1": invalid syntax

Setting it to 0 also does not work.

So now I’ve ended up with essentially a dead SyncThing instance because it believes I have run out of space, which is not the case.

So, is there some way around this limitation?

It should, as that disables the check. Note however that there are two different things here - a per folder setting which seems to be the one you are running into, and the home disk free percentage, which is for where the database lives.

Ok, this is strange… I tried at least a couple of times with 0 and it did not work. Downgraded to 0.11.19. The config option was removed. I added it manually and manually upgraded back to 0.11.20 and now it works…