Slow Transfers

Running syncthing on a dedicated Hetzner box and also my home unRAID server. This worked really well when I first set it up but lately the transfer speeds are less than 1MB/s when I’ve seen like 25MB/s in the past. Port forwarding is in place on the default port 22000, and I’ve even disabled relaying to ensure I had direct connections between the two but still very slow. Any ideas?

There are many prior forum threads about slow transfers, please use the search and try out what was suggested there.

1 Like

I tried that before I posted. Ran across a number of posts about bugs and modifying some advanced settings but wasn’t sure if that stuff was still current. The bugs appear to be addressed but I’m pretty baffled by this inconsistent behavior. This morning I saw transfers 30+MB/s and nothing changed since last night. Transfers by other means seem to be unaffected so something is going on with Syncthing itself. I’ll continue to use the search function and see what pans out.

There is also some content in the FAQ.

I’ve worked through everything in the FAQ, seems like basic port forwarding stuff for the most part and I’ve confirmed I’m not going through a relay. The part that really confuses me is getting 300KB/s and then later getting 30MB/s with gigabit connections on both ends and no changes on either end. Now it’s going halfway across the globe Central US<->Eastern Europe so maybe something is happening in between but like I said other transfer methods don’t seem to be effected. I do see a lot of INFO: Listen (BEP/tcp): TLS handshake: EOF in my logs, I searched for that as well and found a lot of info where clients weren’t able to connect but in my case the clients are making direct connections though I’m questioning the quality of those connections.

If its all large files, then I would not expect a high variance in transfer speeds. If its mixed, then the rate for small files will tank, as fsync on a 1kb file and fsync on a 100Gb file equally takes around 2 seconds, which affects the rate drastically for small files, but I assume you already seen this comment from me in other threads, as I always bring this up.

If its not that, then I can’t really tell you much. Suggest you setup something (iperf on a cron?) to monitor network performance over time.

In my case, these were just a few large files. I’ll try another syncing solution and see what happens since the link seems fine otherwise.

Keep in mind too that if you’re syncing small changes to large files most of the work is copying data on the destination. Transfer rate will be low because comparatively little data needs to be transferred to begin with.


No changes to the file were being made after they populated the syncthing share, no excessive disk i/o or other network traffic at the time the transfers were happening. I’m usually pretty good at resolving these kinds of issues but whatever is going on here seems to be only effects syncthing transfers. I setup alternative sync software and it appears to be unaffected. Hopefully this gets resolved in the future as syncthing is my preferred method but 12 hours to sync 8GB over a gigabit connection is a deal breaker for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.